Ok, some problems with 1.2.68 (unreleased test version)

I editted my “No Issues” thread to bring the minor problems to this thread since now I see other true concerns. Sorry for the corrections, this has been a little confusing to figure out.

When a new device is added or removed from the network, the Network does not appear to refresh unless another tab is selected and then the Network tab.

Correction of original comment: I think I mistated (I originally said my GW client did not appear in Network) and must state that my Glasswire client machine DOES show up in Network – certainly it is there now. That was a request several others also had made. BUT after I changed to a different router (subnet) and then back to my usual subnet, my machine shows as a machine from the other subnet. This could be confusing. But wait, there’s more. I decided then to add a label for my machine “RichWin10” (good feature you added :<). Following that, I exited Glasswire, verified with Task Manager that GW was NOT running, DID NOT reboot and then restarted Glasswire. With that my machine appears on Glasswire with a new IP address, no Device name, but with my new label intact. (I assume the IP was changed when I had previously reboooted, but I failed to see that change at the time.)

This shows my client as a Westell subnet machine BEFORE I added my label.

The RichWin10 machine is not currently on the Westell subnet, but is on the Netgear R7000 subnet.

As reported some months ago, the Netgear router extender (WNCE2001) does not show in the Network list. The actually extender IP is – instead, GW shows the Yamaha device that it connects – that is the So GW shows the Netgear externder device but with the connected device IP. (The Netgear Genie app has problems with this also – it will change the IP from …2 to …8 and back again and again while I watch its display. I never shows both.) Ideally, both IPs and devices should show. (If I access the router browser interface directly using URL, Netgear’s table for Connected Devices does show both device IPs properly, though it cannot identify the connected Yamaha – not surprisingly. It does identify the connector model number.)

Finally, apparently I don’t know what the announcement email about this new release (which has oddly disappeared from my email account) means by the statement about Alerts being marked as Read when the “x” in the upper right of the notification is clicked. Unless I explicitly click on “Mark all as Read” (as always), the alerts still show as unread. If I click on the alert bubble to open the notification box and click the “x” to close the box, the alert(s) is/are still not shown as Read.

1 Like

Reported to the team, thanks!

For the alerts, if you get a desktop notification and close it then the (1) doesn’t appear in GlassWire as an unread alert.

Ok, thanks. (Doh! Forgot about what you mean by “notification”. Got it.)

This applies to the capture below – I’ll relate this to my first post later. If this sounds confusing, you can imagine how I feel.

Note that I have changed to my DSL subnet, yet the Device listed says Readyshare and Netgear which belong to my wireless subnet router. But the label is correct: Westell Router. To this point (note the First Seen 4:46) at 6:30, the Westell info has not updated. Previously I had seen it update to something like Westell.router.com (don’t remember exactly). Actually I have seen two different Westell designations in the Device field concluding with that last guess. It has not been unusual for GW to report several different Device ids over time.

This connection had been in place at capture for 10-15 minutes, which has allowed most devices to be added to Network. But my GW Client is NOT shown (RichWin10).

The device is not known to me – and GW is not helping me identify it. I’m SURE (no question) it is NOT an outside device – there is no one within 300 yards of my house – so I can take my time figuring it out.

My android devices took a while to be captured by Network, but they are here. Note the over-write for Rich Phone.

Once I click Reply on this post, I will be switching back to my Netgear router.

Having returned to my Netgear subnet for several minutes, this is now what is in Network.

LATER: Ok, stab in the dark guess, I think if after changing subnet, if I Exit GW and restart it, GW will correct the Defice info. Below is the outcome. Notice that my GW Client RichWin10 is identfied by IP addr. Also note the IP for the wifi extender WNCE2001 is now the actually extender, where in the previous capture, the IP shown ( is actually the Yamaha device connected to it. (I can determine that by comparing to the Netgear Genie display.)

Do you get this problem always or time to time?

1 Like

Certainly most of the time. I don’t remember any instance of Network refreshing without my intervention by switching to another tab first. (This is a long post – I hope it will be carefully read as I spent significant time providing the information. I say that, because there have been time when it appears anything that we provide as testers is simply ignored.)

Specific example, when I came on this morning, this is my Network – this held for more than 10 minutes before I deliberately added my cell phone to this subnet.

I waited more than 15 minutes (replying to Remah’s post) after my cell changed subnet – no change to Network. Then I clicked the Usage tab and right back to Network. This is the new display. All the same devices are present with the addition of the new cell phone. Also notice that my Glasswire client (RichWin10) is not shown at all in either capture. There have been instances when I have seen RichWin10 appear, but I’m uncertain of the circumstances. See more below the capture.

I’ve now switched to the DSL subnet and am waiting for a refresh. Changing windows to write this comment and then back to the GW window did not result in a refresh. Now I’m waiting for my own imposed 15 minute timeout.

Let me shake the trees a little. Several days ago, I asked for the Glasswire Polling Plan. There has been no direct response (just a “like”). It’s rather difficult to test the Network tab without knowing the polling parameters. Simple example, I’m now waiting 15 minutes to see if Glasswire will self-refresh Network. I would expect GW to do that self-refresh ever 1 - 5 minutes – so I have to wait longer (often a pure waste of my time) to see if GW will refresh. If you would provide the polling strategy, I would know how long to wait and could provide better information. (And be a lot less frustrated with your lack of response.) If you don’t want to publicly post that info, the do as I suggested long ago and set up a unique section on the Forum for those who are running your test releases to provide and discuss the information. There you can allow just testers to see your strategy(ies).

Ok, after about 10 minutes (while I was writing the above) the Network display changed. But notice that only the Device name for the router changed – even the Label did not change (this router is labeled “Westell Router”). And all of the devices are still the devices connected to the Netgear R7000 subnet. Now I’ll try to manually refresh (click Usage and back). Go to next capture.

After the “manual refresh”, this is the Network tab. All of the info now reflects the DSL subnet. The only possible discrepancy is the GW id of the Westell Router as “Netgear” – but that may be the actual manufacturer (I don’t know), and this router always has the info “Netgear”.

We’re changing how this tab works for our major new update. Once that update is out this tab should refresh much faster. I think currently the tab should refresh every few minutes depending on the network.

We just sent out a new version to the testing list, did you get it?

Continuing the above discussion, after posting that, I immediately changed my subnet back to the R7000. I then waited more than 15 minutes for a refresh. (Went to get a cup of coffee, talked with my wife about updating her Yoga2 to the latest released Glasswire, and then just twiddled my thumbs. Thankfully, I have some good blues playing.)

No refresh. I swapped windows, opened this new post and went back to GW – no refresh. I tried a manual refresh (excuse me, I clicked Usage and then back to Network) – no refresh. Even after three attemps and 5 more minutes. Now I’ll exit GW to try to refresh. Ah, sucess! After exiting and restarting Glasswire, the Network tab shows the correct subnet. This is more than 20 minutes after I actually changed back to my R7000 subnet. Notice that now RichWin10 appears in the Device column – but the label says it is my wifi extender and the IP address shows indeed that is the Yamaha AVR that I have connected to the wifi extender. The device name is bogus.

Several minutes later while I was typing, Network did refresh and picked up my other printer and my phone. See the second capture below.

Ken, yes I am using the new test 1.2.69 for all this discussion (to try to capture the DLL error – no sign of that error as yet).

Ken, if you read the details of these my two posts this morning (three including my response to Remah), you will see that GW Network is NOT refreshing every few minutes. Not even close.

I’m very aware that you have the new version coming which I’m looking forward to testing when you are ready. That’s why I’ve providing all this detail and asking for information. I want you to have the chance to fix these problems now that you are working to improve the current Network tab.

@richlife69 Yes, it’s true our current implementation is not perfect but we’re redoing this tab with our major update. It’s difficult to make many changes with our current implementation unfortunately.

For me on my network the current implementation works pretty good, but our new one will be a major improvement. Thanks for your patience while we work on that update.

No issues on the patience – as I said, glad to have the chance to work out issues with this version. I didn’t necessarily expect things to be fixed in this release, but I still want to report issues as you make releases.