Peculiar recurring crash

Seasons greetings and all that.

I have a strange issue with Glasswire 1.136b (free edition). Ever since updating to this version, at precisely midnight each day, the application will crash and Windows will present me with a small error dialogue stating simply that “Glasswire has stopped working.” I am then unable to restart the app until at least a full minute has passed, thus making the time 00:01 AM.

I am running Windows 10 32-bit Home edition, and apart from this recurring crash, everything else has been working as it should with your product. This issue was not present in any of the previous versions of Glasswire that I’ve used. I’ve tried fully uninstalling and reinstalling, but the problem persists.

Hoping you can shed some light on this. Many thanks!

We had one other user report this. Can you try upgrading to our latest version we just released and see if this is solved? Just go to

Thanks for your response, Ken.

Just upgraded to 1.139b. Will let you know if the problem persists.

Latest version still crashing at Midnight, unfortunately.

Do you use any other software that makes some change at midnight? Very strange. Nobody has ever reported this before.

Is your Date/Time set to the correct date/time and does it show the same as it does in GlassWire?

Yes, both the system time and GlassWire time match and are correct.

As far as I’m aware, there’s no conflicting software on my set-up and certainly nothing that makes any time-related changes at Midnight or otherwise.

If I’m completely honest, I don’t really expect a resolution to this. It appears to be far too nuanced an issue to be able to replicate, or, indeed, to be able to properly investigate. It’s a minor irritation in an otherwise very good piece of software that I use for free, so I’m quite content to put up a single minute of idiosyncratic dysfunction.

I did find a thread on this forum entitled “Changing auto DST setting crashes Glasswire UI” when I was googling the fault module (Qt5Gui.dll) and wondered if it could be related in some way? I can’t post the URL due to being a new user, apparently.

Did you try a clean reinstall? Make sure you Deactivate Glasswire>Uninstall>Reboot>Go to C:\ProgramData\Glaswire Folder and Delete>and install the new version. Note C:\ProgranData is a hidden area so you can copy and paste in the RUN Command %ProgramData% then Delete the Glasswire Folder before reinstalling.



Microsoft MVP Consumer Security

1 Like

Made no difference, sadly. Thanks for the suggestion, though.

I am also seeing this crash. Crashed right at midnight, and then when I restarted the app back up, it crashed again, then I started it up again and it worked. Not sure what the deal is. Is there anything I can provide to help here?


Same here for me. Using Version 1.1.39b. And it only crashes for me when I am on the “Usage” Tab and have selected “Day” in the top right corner… Then it’ll crash at 00:00 and at 00:01 I can select the Usage Tab again without any issues

Please do the following:

  1. Run regedit.exe
  2. Open key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps
  3. Add a new key “GlassWire.exe” under the LocalDumps key
  4. Add a new DWORD value under the GlassWire.exe key. Value name “DumpType”, value 2
  5. Add a new STRING value under the GlassWire.exe key. Value name “DumpFolder”, value “C:\users\Desktop”
  6. Wait for another crash of GlassWire.exe. The dump file will be created on the Desktop.
  7. Send the dump file to us under our “bugs” email if possible.


Hey there.

E-Mail is sent with 2 dump files. One when it crashed while running and the second one when it crashed as soon as I selected Usage - Day

Edit: Takes a bit. Dump files are quite big and connection is slow to upload … ^^

Edit2: Email has been sent :slightly_smiling:

1 Like

We got it. Thank you!


Paddy’s suspicions about the problem occurring whilst the ‘usage’ tab is selected appear to be entirely correct. It’s the tab that I’ve had open at every crash, as it’s essentially my default GlassWire view. So, just before Midnight I switched to the ‘graph’ tab and GlassWire stayed entirely functional, with no problems whatsoever.


Thank you for reporting this problem. Due to the crash dumps submitted we were able to reproduce and fix this bug.


Great news! My thanks to Paddy for his crucial contribution, and to your team for chasing down the issue :smiley:

1 Like

Great to hear that. Thanks guys! :slight_smile:

1 Like Please upgrade to the new version that should fix this.

1 Like

Thanks! :slight_smile: Will test it asap

An Update: Seems to be fixed. Cheers guys :smile: