Remote Desktop Authentication Error

When my Glasswire firewall is on, I can’t connect to other computers using Remote Desktop. When I turn the firewall off it works without issue. This started happening very recently, I had no problems until a couple of days ago. Any help on this issue would be appreciated.

@tevfik

Do you just use Windows RDP, or what remote desktop app are you using?

Do you see RDP blocked under the firewall (or the relevant RDP app you’re using)? Please note there is a search icon on the top left side to the left of “apps”.

Are you in “ask to connect” or “click to block” and if you go to your top left menu in GlassWire and choose “About” what version do you have?

I use RDP. It is not blocked in firewall. Version 2.2.241

Please update to our latest software and see if it solves the issue.

Also, in case it does not solve the issue are you in “ask to connect” mode or “click to block”?

Alright, never mind it turns out I misdiagnosed the problem, it wasn’t the Glasswire that was causing the problem. Thank you for your help.

2 Likes

@tevfik

I’m glad GlassWire was not causing RDP issues.

Also for anyone else in the future please note GlassWire can detect RDP connections! This is useful for security reasons so you can be sure there is no remote desktop connection on your PC where someone can have remote control of your computer or server.

Go to our top left GlassWire menu and choose “settings” then “security” then find “RDP detection” and switch it on.

Thanks again for using GlassWire @tevfik and let me know if I can do something to help in the future.