Remote Monitoring failed

i recently bought the basic version to try the remote monitoring option for my other PCs however; when i attempted to connect the communication failed for a reason that im not aware off!!

can someone assist me to establish a proper communication?!!

Sorry for the problem. What error do you see? If you try using no password temporarily can you connect? Try leaving a blank password on the remote PC. Then you can rule out it’s a connection problem and not a password miss-type.

refer to the attached photo, if i remove the password the allocated PC will be removed from the list?!!! therefore i have to use a password, i tried the log in password for windows unfortunately did not operate

In that case, please try a simple password and see if you’re able to connect. Does your network require port forwarding for your router? It’s difficult to give instructions for some networks with port forwarding.

Is the remote PC in “Ask to connect” mode? If so could you change it to “click to block” and try to connect again?

can you please simplify the steps to disable the ask to connect mode!!!

Our user guide is above. Go to the Firewall tab, then below there is a pull-down menu and make it say “Click to block” instead of "Ask to connect. Sorry for any confusion.

i tired port forwarding, it did not work, i tried your method and still no respond from remote server, i checked one of the old posts in the form and one guy wrote the port forward which i did also and it did not work,

Please try these instructions exactly.

Your Remote PC:

  1. First go to the top left GlassWire menu and open settings\server\remote access;
  2. Check the box “Allow remote access by password”;
    3.Click “Change password” and set the new password. Try making the
    password simple for the first connection only, to be sure you don’t have
    a typo.
  3. Click OK;
  4. Open settings\server\general and make sure that the “Remote access state” is “Allowed”

Local PC (the PC from which we are going to connect to the remote PC from):

  1. Open Settings\Client\Remote server;
  2. Click “Add new server” and select it on the “Server list”;
  3. Type the name of the server;
  4. Type the IP address of the remote server; Go to www.whatismyip.com3 from the remote server if you’re not sure.
  5. Type the remote server password, which was set previously;
  6. Check “Enable connection”;

Click OK.The connection process should start. If the connection was
successful please use a secure password, or limit connections from a
certain IP address.

Did the connection fail? What is the error message you see when the
connection fails? Are the local and remote versions of GlassWire both
our latest software versions?


unfortunately it did not work, the app tries to connect but then i receive a failed attempt, meanwhile i uninstall it from one computer and want to install it in a newer system, the activation code refused it, can someone help ASAP


We released a software update yesterday that makes some changes to how GlassWire connects remotely. Please upgrade your local/remote PCs.

You may need to do some port forwarding no matter what version of GlassWire you are using.

when you are saying local/remote that means i have to install the glass wire in both computers and the main one is just acquisition the data from remote computer?

alright it is working now,

1 Like


Looks nice!

although it work fine at the moment but not satisfied with method of operation of the application, i thought i can install the app in one computer and it will analyze the whole network like wire-shark,

GlassWire cannot currently monitor the entire network. To do so requires access to the router unfortunately but we are looking at ways to do this in the future.

The method we use with agents and remote access allows you to see traffic in detail along with application detail and this is information that would not be available in Wireshark or similar software.