Repeatedly getting "Attempting Connection" on "Usage" tab

Its preventing me from seeing the data because as soon as it starts populating the list then it will give a message stating that its “Attempting Connection” then try to load it again. Seems to be doing that forever, and its reading a lot of data from my harddrive as it works on this.

Ive been using the application for about one week and i got quite a lot of connections and large transfers.

Im on Windows 8.1 Enterprise, fully patched.

System is roughly
Intel i7
32gb ram
SSD system drive

PS: I was not able to upload a picture of the error message because im a new user…

Thanks for reporting this problem. I think we know the reason for this error and we hope to have it fixed in the next release.

UPDATE: April 2016 This has become a popular thread due to Google searches. I wanted to post the solution at the top of this thread to help save time.

To solve the problem uninstall GlassWire, then reboot, then reinstall our latest version and choose “clean install” in the installer.

1 Like

Nice, it seems to have gotten worse since i made the post.

After posting i checked Task manager and the Glasswire service was munching in excess of 1gb ram/15% disk so i killed it.

After starting it manually now and starting the client im not able to stay on any of the tabs without getting the “Attempting connection” error every few seconds.

Hoping for a fix soon :slight_smile:

Thanks for the swift reply!

1 Like

Just a quick notify that this is not fixed in 1.0.24b :frowning:

Strange. I have never seen another report about this via email or anywhere so it’s hard for us to recreate and fix it. Let me see if our dev team has some ideas.

1 Like

Ok, sounds like the problem is local then. After the last reply from you guys i figured it was a known problem so i didnt think any more about it.

I will try to uninstall and reinstall the application and see how it goes.

1 Like

Please try to clear your history as temporary solution. This can be done via the UI (Settings/Client/General) or you can remove/rename the database:

  1. Stop the GlassWire service;
  2. Rename the C:\programdata\glasswire\service\glasswire.db
  3. Start the GlassWire service

Are you transferring major data with and multiple connections with bittorrent or something similar? Please let us know if you feel comfortable explaining so we can try to recreate the problem and fix it.


1 Like

Actually Ken, I’m having the exact same problem, on Windows 7 SP1, and on my part, yes i’m transferring major data with µtorrent.
System is :

  • CPU: Intel® Core™ i7-2600 CPU @ 3.40GHz (3392.34 MHz)
  • Memory: 8175 MB
  • OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build
  • Graphics Card Vendor: NVIDIA Corporation Graphics Card: GeForce
    GTX 560 Ti/PCIe/SSE2
  • Windows Graphics Driver Version: 9.18.0013.4052
  • OpenGL Version: 4.4.0

My µtorrent opens with the windows session, is source for about 40 files at all times (even if their traffic is rather low).

stopping the service and renaming the glasswire.db file, seems to solve it for the time being, until I guess it reaches a limit again :).

If need be, I could send you the faulty .db file to help you track down the problem, provided you respect your own disclosure policies :slight_smile:

1 Like

Tried you suggestion but this did not help.
I also did an uninstall and install of the application without any change in the behaviour.
The strange thing is that it worked nicely for a week or so when i first installed it but since i got this issue its not worked correctly at all.

I am running a torrent application with anything between 10 and 60 active torrents at a time, rough throughput on a day would be between 5 and 20gb.
I also stream data from this PC to two other PCs in the household, as well as having a streaming service open most days (, so i guess you could say that i get a lot of data each day.

Service is still using quite a lot of memory, at the time of writing it fluctuates rather wildly betweem 600 and 800mb ram.

I will uninstall the application and do a proper restart of the system now. After that i will reinstall again and see if there is any change,


This did not help, i recorded a small webm to better show how it looks in resource explorer…
Pay attention to the memory usage as well. This was done without utorrent or any other large network load.

1 Like

I have the same situation. I was using it a few weeks ago with no issues what so ever and now it will not connect. What can be going wrong???

We will continue to try to recreate this bug so we can fix it. Thanks for reporting this.

1 Like

Do let me know if i can provide more information like logs or whatever.

Just be specific and i can get you whatever it is.

1 Like

Same problem here, and it happened around the same time as for original author, a few weeks ago.

Windows 8.1 Update 1 x64

Is it possible we could’ve blocked some local service or a Glasswire service that happened to look “suspicious” to all of us reporting here? Since I can’t see much after re-installing, because it gives that error, I didn’t get to see whether my old list of blocked apps is there or not. But I think it wasn’t…so I don’t know.


I have the same issue on Win 7. It’s a recent system install and it was working for 24 hours, but it started reporting “attempting connection” after I applied standard Win 7 patches from Windows Update. I’ll try uninstalling and reinstalling to see if it’s a firewall permission issue.

I’ll ask our quality assurance team to test with our most up to date patched Windows 7 and see if we can recreate it. Thank you.

It’s possible that you have corrupted db. Could you please try to stop the service, delete/rename %programdata%/GlassWire/service/glasswire.db and after reboot look if it help?

It’s working again after installing all available Win7 patches, then uninstalling, rebooting and reinstalling. I’m assuming some correlation between patches or permissions.

Of course, if the problem was a corrupted db, uninstalling would fix that. So that’s a possibility too.

1 Like

Glad to see some users able to fix their problems, mine persists however :frowning:

The problem came back a day or two after it seemed fixed. Application would start and show viz, then after 30 sec the UI would start to lag and go into the “Attempting connection” loop.

I stopped the Glasswire services, renamed existing glasswire.db (the size of which was 350MB), rebooted. It’s now been working for the last 10 minutes with no lag.

Win7 Ultimate (US), SSD system drive.

1 Like

I know this is an old thread but as far as I can tell this is still an issue, and I’ve been having the same problem for a while now. I know that I use a lot of bandwidth, usually around 100GB a week. As far as I can see the Glasswire service is recording correctly because when I select the bandwidth tab I can see my stats briefly, but after a second or so it flicks over to “Attempting connection”

If I load the client and select the “Day” tab on the Usage panel it works fine, as soon as I switc it to “Week” it loads my stats and promptly crashes.

I have a screenshot of the client but I can’t post it because I’m a new user, the service crashed immediately after taking the screenshot.


1 Like