Repeatedly getting "Attempting Connection" on "Usage" tab

Thank you for your report. We’ll revisit this issue.

I have found on 2 occasions now that once

C:\ProgramData\GlassWire\service\glasswire.db becomes too large it seems to cause this problem.

I deleted this file along with “storage.db” (though i do not think this is necessary) both times it happened, restarted the glasswire control service either directly or by rebooting the pc and the problem stopped and glasswire operated normally with no further issues.

Also in answer to one of the posts concerning running a torrent program, I suspect that this would increase the size of “glasswire.db” very quickly due to the amount of connections that are opened when downloading / uploading data.

As an aside note, this program is very memory hungry and cpu intensive and it would be benefitial if this could be addressed (if possible) in the future.

Aside from these 2 issues I think the program is excellent and I would like to keep using it so thanks to the dev team!



Once glasswire.db becomes too large it seems to cause this problem.

It seems that’s the case for me too and I did the exact same steps you did to get GlassWire to operate normally again.

I did an entire day of torrenting with GlassWire running and the .db file peaked over 100MB in size.

I’m assuming this is going to keep happening so for now I exit GlassWire and stop the service when doing P2P.

Hopefully the issue can resolved in future. Great program otherwise!

1 Like

As a quick update, I’ve installed the latest version (v1.0.28b) and it no longer crashes on the ‘Usage’ tab, but performance takes a massive hit when you have a large database. Even resizing and moving the program window is a chore on my PC (2.8GHz i7 860 and 16GB of RAM).

Would be great to see this addressed at some point, when looking over the last months usage the program is almost unusable. If I set it to Weekly or Daily then it works fine.

We’ll continue to improve this in the future. For users with a lot of network activity like torrent users we may have to recommend they only save around 7-15 days of data for now. We plan to add a setting so users can choose to only save one week of data instead of unlimited.

Hi, had same problem just un-installing and re-installing. Done same action a couple of times but fault repeat when run. Last I browse c:\Program Data\ after un-install and found GW folder un-deleted, corrected and re-installed: OK!
Even using RevoUinst the folder was saved after un-install, probably a ‘by design’ GW’s feature.
(GW 1.0.35b)

I installed 1.1.15b a few days ago and started getting this problem: about every 2 seconds, “Attempting connection” would appear and it would connect for about 2 seconds and repeat. I also noticed that my alerts history was now blank.

Clearing All history in the settings resolved it almost immediately; perhaps the empty alerts history indicates a corrupted history.

My glasswire.db was and still is 192K.

I recommend completely uninstalling GlassWire, clearing the GlassWire programdata folder, then rebooting, then reinstalling and see if that solves it permanently.

I don’t understand. I didn’t need to do all that to fix the problem; I only needed to hit the History: “Clear” button next to “All”. it’s been working fine since.

1 Like

Hi all

I’m brand new to the forum, so excuse me re-visiting what seems to be an oldish thread.

I installed Glasswire for the first time 2 days ago (7 July 2015) and for first 24 hours it was fine. Yesterday had great graphs, all the tabs worked fine etc. Really enjoying the program’s output and capabilities.

However, when I started my machine today, I am getting this same error about “Attempting Connection”. I have a desktop machine, Win 8.1 and use Chrome as my browser.

Would appreciate any suggestions. Thank you.

Did you get a chance to uninstall GlassWire, delete your programdata folder for GlassWire, reboot, then reinstall? Please let me know if that helps.

I have tried this today and it now works OK. Thank you.

I will keep an eye on it over the next days and see if it is still working after 48hours or so.

many thanks again


I’m sorry to report that my GlassWire has stopped working again. After running fine for about 2 days, starting up as normal when PC was booted up etc, and fine with re-starts for one reason or another, today when I booted up PC it gave me that “Attempting Connection” message and would not run properly, just attempting to run again and again and again.

I have uninstalled it again now and am going to leave it. Good luck with finding out what is happening. I will revisit the website in a month or two to see if a solution has been identified. But thank you for your help in the meantime.


A lot of our users helped us find this problem by emailing our helpdesk. Our next update will be out in a couple weeks and we hope you’ll try it!

Looking forward to that… I reported this one and a half year ago and ive been waiting for a fix… :smile:

This happened again, 17 days since last time.

Keeping last week’s history didn’t resolve it; I had to clear all history and the problem immediately cleared. (no reinstall necessary)

1 Like

The problem recurs almost every reboot.

Still with 1.1.21b, the problem occurs when GlassWire starts, irrespective of reboot. I can close GW–which is running fine–and run it again a few minutes later and the “Attempting connection…” loop may resurface.

As always, clearing all history (from Settings…) immediately corrects it.

Thanks. We’ll keep trying to figure out why this is happening for some users.

Just happened to me too (Win8.1 64bit) with Glasswire v1.1.27b. Clearing settings didnt help, but renaming glasswire.db file helped.

Previous day i was downloading game through launcher (it uses p2p), and to limit upload of that launcher i installed netbalancer too. launcher and netbalancer and its services were closed and stoped, that didnt fix problem too, even after computer restart.