Service stopped running after installing audio and USB 3.0 drivers [Solved with windows updates]

Hello dear comunity,

I encountered my first problem with glasswire 2 days ago when I tried to solve an audio problem.
Now that my audio and USB 3.0 finally works, Glasswire was losing connection every 10 secs. 3 secs to connect back again and then 10 secs later it was trying to connect back, etc.
I tried to unistall Glasswire and reinstall it, then the service stopped definetly to work, even the new beta 1.0.44b.
Does Glasswire have a driver that somehow disagree with my audio or USB 3.0 one ?
I used Driverpack Solution to install my drivers, was it a bad idea ?
Does this have even something to do with Glasswire problem ?

I’m running on a fresh windows 7 restored to default settings since yesterday.
The audio driver is Realtek high definition audio
The USB 3.0 driver is Fresco Logic xHCI (USB3) Root Hub

I’ve read last versions help topics and I didn’t find my problem. Or I might have not understood it was the same problem.

Discovered Glasswire few months back and now I can’t imagine my computer without it.
Thank’s for your time & software.

Sometimes rebooting after an uninstall will help. Can you try going to add/remove programs and removing GlassWire completely? Then reboot, then try installing the latest version again.

Thank you for your fast reply, I did as you recommended, plus deleted the appdata GlassWire folder.
When I reinstall, it says “windows requires a numerically signed driver”.
The installation completes, the software launches, but then again I’m stuck.

I don’t understand because your driver IS signed, ain’t it ?


Please download the security update discussed in this article to solve the problem. Please let me know if that fixes the problem.

1 Like

Apparently applying windows updates as you suggested solved the thing.
I’m eager to crawl again in front of my kicking asses firewall interface. Thank you Ken.

I’ll let you know if there’s further problems. Many thank’s for your time on this minor issue.


1 Like

We are glad it worked!

1 Like