SMB2 Traffic Blocked

Hello, with the firewall on I’m unable to connect to a local SMB2 share. As soon as I switch it off it works fine. I have about 25 applications blocked with the firewall but can’t figure out which is responsible. I’ve tried temporarily allowing one app at a time and working my way down the list but have not had any luck so far. This is for Windows 10.

Using Fiddler I can see there is an initial request header of:

and a response of
HTTP/1.1 200 OK

So that’s good. But then the next request header of

gets a Response Header of:
HTTP/1.1 405 Method Not Allowed

Any ideas?

Any chance that this just started happening recently? I have begun having problems since upgrading to 1.1.41.

Please go to the GlassWire Firewall tab and let us know what Firewall mode you are in? Are you in “Click to block” or “Ask to connect” mode? Thanks for reporting this.

@glassfire, it had worked before, but I’m not certain if it started with 1.1.41.

@Ken_GlassWire, I’m currently in “Ask to connect” mode.


We fixed this problem for another user who had a similar problem but the update isn’t out yet. Please be on the lookout for the update, or email our helpdesk with a link to this thread and I can send you a test version.
For now switch to “click to block” mode until the update is out if it’s safe to do so.