[SOLVED] GlassWire 1.2.61b - still cannot install over w/out issues

Just ran the installer for 1.2.61b. It is implied (yet again) within the email

Please install this version over your current version, or do a clean install, it’s up to you.

However, every time I have tried this in the past and to this present version, I receive issues when attempting to start GlassWire.

The GlassWire service stopped running.
(Restart GlassWire)

Hitting connect, it will attempt about 5 connections and then reveal the same message.

I attempted the following…

  • a restart of my computer == issue persist
  • completely kill the process and restart == issue persist
  • restart as admin == issue persist

So it looks as if it is indeed required that you do a clean install and wipe data every upgrade? Is that correct.

Here is some additional info:

  • System Specs:

  • Computer Type: ACPI x64-based PC

  • Operating System: Microsoft Windows 10 Pro

  • DirectX 12.0

  • CPU Type: QuadCore Intel Core i5-3570K, 4333 MHz (42 x 103)

  • System Memory: 8152 MB (DDR3-1333 DDR3 SDRAM)

  • Storage ATA: ADATA SP550 (2F5220059606) SSD

  • Installation Method:

  • Installed current beta over last known stable

  • no additional and/or unusual adjustments have been made

  • GlassWire is located on the same SSD as the system OS

On my system, I was able to install over the old version, without stopping the older version, without any issues.
Version 1.2.61b automatically stopped and uninstalled the previous version before installing the new one.

  • Windows 10 Pro x64
  • Intel Core i7-4790K 4.4GHz
  • 16GB DDR3 memory
  • 128GB Samsung SSD 840 Pro
  • Asus STRIX Geforce GTX970
  • Corsair 850 Watt PSU

I had the following apps running:

  • Deluge with 20 torrents seeding.
  • Google Chrome with 15 tabs open.
  • Mozilla Thunderbird.
  • Putty connected to my VPS.
  • OpenVPN GUI.
  • Razer Synapse.
  • Stack.
  • Google Drive.
  • SoftPerfect RAMDisk.
  • Samsung Magician.
  • AxCrypt 2.x
  • SpyBot.
  • Pushbullet.
  • Soundswitch.

It is running very smooth here.

Great to hear that! So happy for you! :smile:

As I stated previously, it stopped the service on install, removed the old version etc etc. However, it wouldn’t start. I had no services running other than ESET, GlassWire and Process Explorer (Oh, and Chrome). I have never been able to get it to restart automatically without issue after upgrade.

I just had to do a completely clean install and thus, all my past data is gone and now setting rules once more. Makes me want to avoid ever upgrading the software.

@JMSolo Please email our helpdesk https://www.glasswire.com/contact/ with a link to this thread so I can give some instructions so we can collect logs and see why this is happening for you.

It is not required to do a clean wipe and install with every upgrade, we think that would be bad and I think our users would be mad at us! :slight_smile: I hope we can fix this for you!

All sorts of words in my email to help[at] - thanks for the assist Ken!

Hopefully I can figure this out, I am curious what it is about either, my luck or my system that may be getting in the way of normal upgrades.

@JMSolo, your CPU appears to be overclocked which might be a reason why nobody else is having this problem.

FYI, the standard CPU frequency for is 3.4GHz and turbo boost is 3.6GHz whereas it is running at 4.3GHz

It’s true, my CPU is overclocked. Hence the ‘K’ Would an overclocked system really cause this type of issue?

Geez, I sounded like a jerk there… sorry bout my bad filter @Remah, just really curious how this would result in the behavior I am experiencing with a simple upgrade. No other softwares have faced this issues on my system during an upgrade. I am curious, is there a way to get others with an overclocked system to speak out?

@JMSolo We got your email, thanks!

1 Like

Overclocking changes timings and can produce subtle and unusual issues.

Are CPU core temperatures well below the spec: Maximum operating temperature 67.4°C?
Do you have have the latest chipset drivers?

One way to virtually eliminate overclocking as a cause of the problem is to run the install while the CPU is at the stock speed. If you still have the problem then it is more likely to be something else.

Yes, I keep everything current… temps are never an issue as the most intensive apps I run are Atom.io, Plex Media Server and Illustrator. Temps usually sit around 42°C. Never go higher than 65 or I have an alert shut down the process… unless I am doing it intentionally.

It’s Intel Panther Point Z77, Intel Ivy Bridge motherboard chipset as well… but don’t know how relevant that would be to the problem.

I could try tempering the beast and see if that matters. Good idea!

Over many years supporting systems, I’ve seen many problems disappear when overclocking is scaled back. In one case, the reduction was only 1-2% to get a Windows .NET application to run properly. Admittedly, it is much less likely today because there is much better motherboard support for overclocking.

You might check if other overclockers with the same motherboard/CPU combination have had unusual software problems.

I would, but I wouldn’t know where to start. This is the only application I have had issues with. But I am going to attempt your suggestion once I am not running anything.


Thanks loads to GlassWire, the new Beta works splendidly. Installed over the past release and the services installed and started right up without error.