[SOLVED] QT5core.dll and msvcp140.dll missing and GW won't run


#1

This problem began this morning when I started my computer. Very frustrating! Why did this happen?!

I had to try and reinstall GW two times, and neither time worked. So, I had to uninstall the problem, then do a reinstall, and I still am getting the msvcp140.dll error.

So I found msvcp140.dll elsewhere on my system and moved it into GW folder, and then GW started complaining about missing QT5core.dll again.

What am I supposed to do to fix this problem?


#2

@stealthmode

Do you use any cleaning software to clean your hard drive? Sometimes these types of apps can delete our files. If that’s what happened you’ll have to do a clean install of GlassWire.

The only other thing that could cause this is some kind of file corruption issue. I haven’t seen this reported before and it doesn’t seem to be a common problem.

If you reboot does it help?


Getting message msvcp40.dll missing with latest GW Elite
#3

It’s none of those.

I found the issue. It’s Visual C++ Redistributable 2015 (x86). I’m on a x64 machine, Windows 10 1709 16299.431. Yesterday it seems that program was updated automatically, I assume beucase it doesn’t show up in my Windows update history. Because it shows an install date of 7/1/2018, but I didn’t install it yesterday.

I realized it also affected MS Word, Excel, etc., after I wrote this thread.

Running modify from the app profile and choosing to repair it fixed the problem.


#4

FWIW, I did a clean install of GW and that didn’t help. I also uninstalled GW, deleted any remaining files and registry entries, then reinstalled GW, and that also didn’t help.


#5

I’m glad everything is OK now. Thanks for the details!


#6

I have got the same problem when i’m trying to run glasswire. there are 2 error messages for missing files of api-ms-win-crt-runtime-l1-1-0.dll file and Qt5Core.dll. please mention a method to solve this problem. i’m running windows 7 and tried on glasswire 2.1


#7

@thushan

Could you try running Windows update? It may solve the issue automatically.

Or, you may have noticed above another user had this to say:


#8

yes. I have installed impotent windows updates on my x64 machine. but the problem is still there. but I haven’t tried that Visual C++ on my machine? what should I do…? should I install Visual C++ manually…?

thanks for you reply.


#9

I have the same issue here.
running W7 ultimate x64 edition, tried many times to clean install GW but all trials were useless.
Can you GW support team assist us to find the solution please ?


#10

Some screenshots for further info.
2018-12-30_213428