Stuck "Visualizing Network"

I also hope to be repaired bugs so fast.

@Ken_GlassWire, is there anything we can do to help you debugging this problem ?

Merlin, any crash dumps sent to our bugs email on our contact page are useful along with all details about your OS and what exactly happened, plus any instructions on recreating the bug. Anything that you think might help is great!

Thank you!

My guess is the Glasswire service is programmed to have dependency on the Windows Firewall service, since itself is not a firewall replacement, but it can block programs by adding rules to the Windows Firewall. If the Windows Firewall is not running, the feature does not work.

I think we can’t do much about it, unless Glasswire itself becomes a standalone firewall, which I think is not its purpose. Or it can disable the feature of blocking programs when detecting that Windows Firewall is not running, but still run the rest of its functions normally, which would be ideal for compatibility with 3rd Party Firewalls.

If the Windows Firewall is required to run, I suggest adding a System Requirements section to the front page, so that at least people know that those who use 3rd Party Firewalls can’t use it.

@Ken_GlassWire, does your service write in the event log ? Because I can’t find any entry, while the service starts then stops immediatly, showing me this message :

(which roughly translates to “The GlassWire control service on local computer has started then stopped. Some services stop automatically if they are not used by other services or programs”)

Is this service supposed to run ?

The only visible symptoms are this service which is stopped, and the main application stuck at “visualizing network”.

My os is windows 8.1 64bits, up-to-date (I just checked), and the windows firewall service is running.

I have the same problem. Windows 7. Tried the suggested Microsoft ‘Fix’ link, rebooted and still the same problem?

Not a good introduction to new software.


Sorry to hear about the problem and thank you for your feedback. We’re working on an update that should be out in the next 10 days.

Wooo! I got it working!

Just wanted to inform of my situation. I installed GlassWire, rebooted, and was stuck on “Visualizing Network”. I always keep the “Windows Firewall” service disabled, so after reading this forum I enabled the service in “services.msc”. Then enabled the “GlassWire Control Service” and VOILA! IT WORKS!

If you don’t want Windows Firewall running you can turn it off in the settings and still have GlassWire work (everything except the Firewall tab). For me, I just don’t need Windows Firewall, so I had no reason to have the service enabled. GlassWire seems like a good enough reason to have the service running now (especially since I can keep Windows Firewall turned off)

So, in my instance, the reason for this error seemed to be because my “Windows Firewall” service was disabled in “services.msc”

Hope this helps!

1 Like

I got the same problem, I tried doing the same as simillarian, but it still doesn’t work :frowning:

Another data point. I had a similar problem. Glassware UI seemed to be running, but was not seeing any new activity, even when I started apps that reported their own internet activity. I stopped the UI and then the Glasswire service, restarted the service, then restarted the UI. It looks to be performing more as expected at this point, though it’s still early.

My system: Win7 x64 with all SPs and updates; default MS firewall and antivirus; wired ethernet.

In case it helps, after my initial install and system reboot, Glasswire saw a bit of “first network activity” and then nothing new for 24 hours.

FWIW, the GW UI just crashed. Nothing in the event logs.


1 Like

Hello Everyone,

We just released an update that should solve this “visualizing” problem Please upgrade and confirm it’s fixed for you. Thank you!

Still doesn’t work for me, I just get this:

Reconnecting doesn’t help, restarting doesn’t work.



Can you try completely uninstalling GlassWire in add/remove programs, then rebooting, then reinstalling the latest version? Sorry for the problem.

I have the same issues as MrTang. I tried uninstalling, rebooting, reinstalling and had no luck. My details have been posted further up the thread.

Another thing that might help is when I try to start the Glasswire service it immediately stops and gives me this error message

1 Like


We need some help to solve this issue. Could you email us your Windows Event Log if it mentions the GlassWire service? It can be found at the “Control Panel\System and Security\Administrative Tools\Event viewer” in the System category.

Our “bugs” email contact is here on the bottom right side of the page. Thank you!

Same problem as Mr.Tang and Cody… Using the latest version…

I guess this problem occurs mainly in Windows 8.1 x64 as I believe their system is of the same config.

I request the developers to try the software on this platform.

Hi Guys,

Check your “Base filtering engine” service, it should be running. Start it if it’s stopped and then try to restart GlassWire service. This may help.

Great work. After the update, it seems to be working fine now without the windows firewall dependency. It seems to run fine at first glance, but will continue to play with/use it to see. Thanks for the update.

It’s running…still nothing

Which update? I’m running 1.0.23 beta