Switching to "Ask to Connect" breaks network shares

So, I just upgraded my server and a few machines to 2.xxx

BUG? or Feature?: Ask To Connect is not allowing excluded items in windows firewall through, and provides no way to allow it either.


  • blocks windows incoming network shares
  • blocks Remote Desktop!!!

Activities Notes

  1. Switching to “Ask To Connect” is turning on the “block all incoming connections, including those in the list of allowed apps” in windows firewall.
  2. Unchecking Windows Firewall “block all incoming connections, including those in the list of allowed apps” doesn’t allow shares to connect
  3. Switching back to “Click To Block” seems the only way.

Document With more detail and visuals


We found this bug and we’re working on releasing a fix ASAP. Thanks for your report.

This bug is seriously ridiculous!
Now I’m searching for the old ver 1 to reinstall.
Unacceptable -.-


Another problem with Ask to Connect is once activated upon restart .exe files not approved will creep through the firewall and either be auto denied access or allowed access without user input. I assume the Auto denied is the way this should work but allowing .exe’s through without user input is a problem certainly when you have a big list of programs stacked in the apps list.

I felt this way at first, but this is still a great product and worth the struggle IMO. @Ken_GlassWire do you have any workarounds?

Just upgraded to 2.0.

Having insane connectivity issues as soon as “ask to connect” is switched on. All issues disappear when resetting the Glasswire Firewall Profile (which puts it back to “Click to Block”).

When is there going to be a fix? “Fix ASAP” for connectivity issues typically means same day in my world.

A word of warning about Ask to Connect. Do not switch this on and off repeatedly as it will break windows firewall and render it completely unusable in which case you will have to reinstall OS in order to get WF working again. Something to do with the White listing of apps. Will get full details of my bro and post.

Never happened to me. This was my bro and he uses windows 10. He is away for Xmas and wont see him now until next week. He told G’w about this among other problems but from what i understand they said this wasn’t possible and there was a falling out over it. but clearly it happened to him and his friend and i had seen the effects of it. the only way for them to recover was a complete re-install. System restore did not work.
For me after i had seen this i un-installed V2 instantly and since doing so (about a week ago) i have not been able to re-install V1 due to errors. So basically i have not been able to use G’W at all since.


Could you ask them to go to the Windows Firewall settings, then choose “restore defaults” then reboot? GlassWire only makes changes to the Windows Firewall and it installs a driver that has no ability to interfere with network connections, so it should not be able to make changes to your PC that would force a reinstall of the OS to fix anything.


Ken with all due respects we are all computer geeks here pal. This was tried and from what i’d seen W’F was completely done (corrupted) . And to be honest my bro wont entertain GW anymore. And before you ask nothing else was responsible for damaging W’F but G’W. He did warn you guys but somehow you guys got into a battle and everything went pear shaped (English slag for Wrong). You can dispute this Ken but, if he had V1 running ok and out of the blue installing V2 everything went wrong then it doesn’t take a rocket scientist to work out why.


Just got off phone to James (2nd person who had corrupted W’F) and he is telling me that he couldn’t access W’F at all (that i didnt know) he was getting errors when trying to access W’F and his Event Log was full of W’F errors. My Brother could access but was getting error when trying to reset and nothing was being blocked/Allowed even with G’W removed. Cant speak with Brother right now as he is away and to be honest he probably wont want to have a convo about this with me.

For the record i removed V2 upon hearing this but couldn’t re-install V1 due to errors which im sure someone else here has reported too.

To OP sorry for hijacking you thread.


Please let him know we are very sorry about the problem.

We’ll have an update out tomorrow.

For people who have connectivity issues if you choose “restore defaults” with the Windows Firewall after uninstalling GlassWire it should solve the problem.


GlassWire’s driver does not do any blocking so it cannot cause connectivity problems, and we use the Windows Firewall API for blocking and we don’t block anything any other way, so it shouldn’t be technically possible for GlassWire to cause connectivity issues that are permanent. But again, I apologize for the problem and it was not intentional.

This problem is now solved, please upgrade https://www.glasswire.com/download/