The firewall not working as expected?


#1

I have a paid version of Glasswire basic.
When the firewall button is green, none of my apps can connect to the internet, even when they are unblocked.(fire button grey)
I need to get control of win10 auto updates on metered internet. The ovarages are way over my fixed income. I have tried several of the things I’ve found, but none of them worked for more then a day or so. Seems MS is playing a game with those who need to stop autoupdate.
With the firewall button green all traffic is stopped. Enabling an ap or service does not allow it to connect for me. With the button grey, I can’t block some apps/services at all. Is this because of the version I bought?
Or have I missed something?
I have Win10 Home
Thanks for any help.


#2

@BlokWin10

What mode does it show under your Firewall button? Is it “Block all” or “Ask to connect” or another option?
ask


#3

It is set to click to block.


#4

@BlokWin10

Something is wrong.

You should uninstall GlassWire in add/remove programs first.

Now go to your “Windows Firewall” control panel and choose “restore defaults”.

Next reboot - IMPORTANT.

Now download GlassWire from www.glasswire.com and choose its “reset firewall” and “restore defaults” options in the GlassWire installer.

Now switch on GlassWire’s firewall and see if the problem continues or not.


#5

Same problem. I am using WIFI and have it set to manual connect. Win10 home Defender Firewall seldom asks for first connect. Sooo, adding apps through the firewall manually as needed


#6

@BlokWin10

Is it working now, or are you saying GlassWire’s firewall switched to “On” still causes no applications to access the network?

Can you give more details on WiFi and manual connect? Are you sure your computer is just not connected to the Internet at all? If GlassWire is not installed does this problem still happen?


#7

Well, we are doing this tread, so yes, the pc is internet connected.
With the firewall button green, all apps are blocked,(set to Click to block) even those manually allowed through Win Defender Firewall. Does not matter if the if the fire button is red or grey, everything is blocked.
As for Manual wifi connection, the tray in the lower right corner of the screen shows available connections with an icon. Click the icon and a menu pops up allowing me to select a wifi connection. Windows also shows if internet is available on that icon. With the glass firewall button set to green, windows reports no internet available.
With out glasswire, things are normal.


#8

It looks like GlassWire has some WiFi connection issues. Possibly related to manual connect. The manual connection option is the only option I have to control internet usage.


#9

@BlokWin10

GlassWire should be technically unable to cause any WiFi connection problems. We use the Windows Firewall API, and it gives no option to just block WiFi that I know of. Or at least we don’t use that kind of functionality in GlassWire.

I have never read a report of GlassWire causing all network activity to cease when its firewall is switched on. That’s very strange.

Does the ISP you use have an application that you must launch and run to create an Internet connection? May I ask what type of ISP you have? Is it Satellite Internet or something unusual at all?

Let’s figure out why this is happening. Thanks for your detailed report.


#10

I am on ViaSat internet,isp is Exede. Nothing special is required to use it. No app is needed to use the internet.The modem connects to the router just as any other would, through a standard network cable. The router is a normal wifi/four network port router(Asus RT-N12). I will be putting on a new router in the next few days.


#11

@BlokWin10

Are you 100% sure they have no special software installed on your PC? The reason I ask is that perhaps some application must access the network and it is being blocked, and that causes your connection to fail?

I will ask our team if they have some clues.

Could you confirm you reset the Windows Firewall control panel as I suggested previously?


#12

Yes, I reset the firewall in the control panel. I did the clean install option in the installer. And no, no special apps for any of my games or software.
I have AVG free, and MalwareBytes installed


#13

I think l found it. I had blocked Host Process for Windows Tasks. When I unblocked that , I can get on the internet. I fear that will defeat any hope of controlling auto update though.


#14

@BlokWin10

If you are using Windows 10 you can set your account as “metered” to avoid Windows updates when you don’t want them.

Please give it a try.


#15

FYI
That setting persisted through a full uninstall and clean install of GlassWire.
(Blocking Host Process for Windows Tasks)