The link to upgrade is dead

I am ready to upgrade from free, but the link is dead. Whenever I click on ‘upgrade’ i get sent to: [404 Not Found

Hi Jim,

Please can you confirm which version of GlassWire you are using?


I have problems to upgrade too. I have Glasswire Free 3.2.490 and if I click the button to upgrade in-app I get the error message “Activation failed”. An internal error has occurred.
If I try to login to Management Console the login fails with the message “Error. Try again later. Something went wrong, please try again or write to support”.
I’ve tried many times to login but I always get the same error message.

Hi @Kels,

Please can you reset the device id by following the below steps:

  1. Stop GW service via the task manager.
  2. Run regedit.exe and remove CloudDeviceId parameter at HKEY_LOCAL_MACHINE\SYSTEM\GlassWire
  3. Restart GW service.

If you continue to have problems then please email in to support


I was using an older version. When I updated to v3 I was able to upgrade. Thank you.

1 Like

ME TOO… Thank you SOO much for your post specifically; I was literally in your situation word for word until just now. I thought it was literally broken, and when I’d call they’d tell me nothing. Made no sense to me as I’m nowhere near subprime anymore and haven’t been for years.