Unable to Block Apps

I have a paid version Glass wire and I had to reinstall windows 10.
Since I have reinstalled and reactivated my Glasswire I am unable to block apps when it’s set to “Click to block”.
It’s almost as if it’s not compatible with windows 10 64.bit
When i click on the app in question the screen flickers and resets.
This is driving me mad.
Thanks in advance.


If you go to the Windows Firewall Control Panel and make any changes there does your PC flicker? Is it your monitor that’s flickering or what is happening exactly?

Do any other applications cause your screen to flicker?

If you change your video resolution does the issue still occur?

Not screen flicker as in display (wrong choice of word) flicker. It’s just the app window scrolls very quickly back to the top. The greyed out flame by the app is not able to be selected. However I can select incognito and the sunglasses show. Its almost as if this is 32bit not working under 64bit. I hav tried launching in comparability mode for windows 7 buts still the same. This is a brand new windows install and windows update. One of the first apps to go on.
Current firewall is fine.

Is it possible to make a Gif or video? Perhaps from your phone? Then email it to us? https://www.glasswire.com/contact/

If you change resolution does it matter?

Nobody has ever reported something like this before so more details would help us find the cause.

Hi, it’s not an issue with display. Forget that side of it.
The problem is that the app doesn’t respond to clicks in the firewall. Trying to click to block doesn’t work. Like I said I have seem similar with old code on 32 trying to work on 64. This was a clean install of windows 10 64. I previously had no issues with windows 7 upgraded to windows 10.
Is there a compatibility issue with the latest windows updates?


There is no compatibility issue with the most recent Windows updates that we have heard of in the forum or to our helpdesk. I also use the most recent Windows updates myself as does most of our team.

We are having trouble understanding what is happening exactly. Do you have any accessibility settings on with your Windows 10 version or any other unusual settings at all?

Is your computer completely up to date? If you run Windows Update again does anything else appear there?

Are you using another firewall with GlassWire?

If you go to our top left menu and choose “About” what version of GlassWire do you have?

The version is the latest update performed yesterday. No other firewall being used. I simply cant click the greyed out fire to block an app. Simple as that. Very slow to react as well.
I have a 32gb ram, 5ghz intel i9, with an m.2 1tb drive.

I will report this to our team and we’ll try to recreate it. Thanks for your report.

I’ll also see if we can provide a special build for you to test to see if we can locate the problem.

@Ken_GlassWire, from the description it could be like a problem I remember reading a long time ago. I think that was resolved by reinstalling GlassWire. But I can’t find the topic or remember the exact resolution.

This is very unlikely to be caused by incompatibility between 32-bit vs 64-bit Windows.

About 90% of Windows 10 installs are 64-bit so this problem would be expected to be much more widespread if it were a compatibility issue.

Unless you’re running an old application, the days are long gone when there were many potential sources of incompatibility.

GlassWire also uses software libraries that are widely used, e.g. Qt, so incompatibility would be likely to be more widespread across other applications.


Please go to add/remove programs and uninstall GlassWire, then reboot, then reinstall our software using our “clean install” option and let me know if that solves it.

Hello, what GlassWire version do you use?

Also, can you please check, how much cpu the Glasswire application is using? @mart Please let us know.

I uninstalled the app. Redowloaded it and installed. I ran the update before I activated it. All is working well again. I hav no idea what was going on still. Happy again.
Thanks to everyone who responded.

1 Like

I’m glad it’s working @mart! Thanks for the idea @remah! I guess something was just corrupted somehow with the UI? Very weird!