Unable to enter Elite key

So I bought the elite upgrade (from pro) and wanted to enter the elite key but this seems not to be working.
What I tried:

  • used the “deactivate Glasswire” option, which only will cause Glasswire to restart but it will still be active
  • uninstall and re-install using the “clear all data” option in the installer

Nothing seems to get rid of the pro key. Besides that this needs to be fixed as a workaround could you just tell me where the key is saved at so I can manually delete it? Appdata? Registry?

1 Like


I’m sorry to hear you can’t deactivate. Fortunately there is a fix that solves this for people who experience this problem.

Please right click the Windows taskbar and choose the Windows task manager, then find “GlassWire” under services and stop the service temporarily (by right clicking it).

Next remove the file license.dat from the C:\ProgramData\GlassWire\service folder.

Now Exit GlassWire at the top left menu by exiting it, then restart the GlassWire service.

Now restart GlassWire and try activating with your license.


Thanks, that did the trick for me!

I had the same problem and this also solved it for me…

I tried the same steps the op did, to no avail…

I can understand the ascetics of keeping the menu clean (and entering a serial number is a one time act)… but shouldn’t there be a GUI based way todo this? maybe buried somewhere?

Thanks for the solution, happy to support a good product.


Yes, there is a way to do it. What you’re experiencing is a bug and it’s not intentional. We had a version of GlassWire awhile back that introduced this problem and some GlassWire users have this problem, but not everyone.

Normally you go to the top left GlassWire menu and choose “deactivate” then GlassWire restarts and deactivates, then you go to the top left GlassWire menu and choose “activate” and paste in the new code there to upgrade. No data should be lost this way and you should keep your history/settings as is.

Sorry for the problem.

Dito to the previous users post.
Irritating to hit deactivate for it to shutdown and come back as a basic. 5 seconds later.
The posted steps solved it.

i have different problem my will not stay activate I need to put my code in every time I start glasswire


A clean install of GlassWire, and a reboot usually solves it. If it does not, do you use Kaspersky? If so please white list GlassWire https://support.kaspersky.com/7834.

no I don’t use Kaspersky I use eset nod32
went i started computer up is time
it run glasswire and it is activated
but it is the 17 th time I restarted my computer

1 Like