Unable to install latest version or uninstall completly


I tried installing the GlassWire update 1.2.109 today and I keep getting the error
"Error opening file for writing:
C:\Program Files (x86)\GlassWire\GWCtlSrv.exe"
and if I click ignore I get GWIdlMon.exe and GlassWire.exe

I have tried turning off anti-virus but the issue appears to be all those exe’s are locked.
"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."
I can’t force give my self permission on it either.

What can I do to get GlassWire up and running again?


I just tried to install the latest version on Windows 10 and got a different error

Setup cannot copy the file gwdrv.sys

It cannot access the C:\Windows\System32\drivers folder

I reinistalled previous version and it works.

Please fix this problem



If you right click our installer and run it as admin does it make any difference?

Do you use any unusual security software that could be blocking the installation?

If you go to add/remove programs and uninstall GlassWire then reboot (don’t forget to reboot) then try to install again using the “clean” install option does it work?


I tried to run in Admin mode but it did not make any difference.
I only run Kaspersky Anti-Virus.
This is the first time this error has occurred, the current version of gwdrv.sys is 2015 so previous updates have not tried to update the file, only this latest version.
I will try to remove, reboot and re-install in a short while.


Ok, I removed the previous version of Glasswire
Installed latest version in normal mode and it WORKED

The version of gwdrv.sys that is installed is
Product version
Date modified 29/05/2015 2:15 PM
File version

So if it is the same version as before, why does the instal try to copy it again?


@themartymonster I’m not sure, I will ask. I’m glad it’s working now. Usually a reboot will solve any problems like this.


The update was attempted not long after I turned the PC on (approx 10 min) which is in effect, a reboot.


After rebooting again the installation worked perfectly, Thank you for the quick replies!


I am facing this problem too


I am facing this problem too}


Did you try this?


“If you go to add/remove programs and uninstall GlassWire then reboot (don’t forget to reboot) then try to install again using the “clean” install option does it work?” then uninstall again?


This is still happening.
I just booted my PC and got a message to say there was an update.
Download it and tried to install it and once again it cannot copy gwdrv.sys
So this would mean that NO ONE looked into the problem when it was reported a long time ago.



We were unable to recreate this problem on our test machines. Sorry for the problem, we investigate and see what happened.

If you go to add/remove programs and uninstall GlassWire there, then reboot does it help?


I just did an uninstall and then an install without reboot.
The version of the file has not changed so as I asked previously, why is it trying to copy the file in the first place when it was not updated?


I’ve been trying to install v1.2.118 the latest version and have been having the same issues as above. I uninstalled previous version, reboot and install the new version as a clean install. Sorted the problem

Problem highlighted was the gwdrv.sys file.


This problem is unusual, and I think it could be dangerous not to double check and replace the files associated with GlassWire in the installer, otherwise GlassWire could theoretically execute a modified driver that’s malware.

For everyone else:

If the GWCtlSrv.exe process is running when this problem happens please end its task, then reinstall GlassWire. Or you can try what @Allan3349 suggests. We are unable to recreate this issue but we’ll check again and try to figure out why this happens so we can fix it.


Incidentally this issue occurred on my Laptop and my desktop both running Win 10.



We’re having trouble recreating this. If you wouldn’t mind, could you try installing our latest update on top of itself and let me know if this error appears again, or not?



Did you use Revo uninstaller or another uninstaller type app to uninstall GlassWire? What about you @themartymonster?



I uninstalled using windows control panel or glasswires own uninstall command. Can’t remember which.