Upgrade to 2.2.241 - fails to connect to local server, how to downgrade?


Since upgrade GlassWire 2.2.241 it is always stuck with this message.

I have followed all the suggestions, none were relevant - WLAN AutoConfig tip, etc.

Can anyone tell me how I down grade to an earlier (working) version?

I’ve been getting the same problem. I can’t use the firewall. When the program was installed, the firewall blocks Internet access to it. :anguished:

Win 10 x64 1909 18363.1082

Why can’t GlassWire connect to its local server and why won’t GlassWire’s graph load?

GlassWire for Windows has a local Windows service that runs locally on your PC. This Windows service keeps track of your network activity for your PC or server. If that Windows service cannot start then GlassWire cannot graph your data usage.

Please note your graph data never leaves your PC, and we at GlassWire cannot ever access that data since it’s only stored locally on your own PC or server. Our privacy policy explains how we can’t ever see your data.

If you are experiencing this problem first try rebooting your PC. If GlassWire still cannot run please uninstall GlassWire in add/remove programs, then reboot your PC (this is an important step in the process), then reinstall GlassWire while checking its “clean install” option in its installer. You can download our latest software from our download page.

If GlassWire’s graph will still not load please check to see if the following Windows services are running in the Windows task manager:

  • WlanSvc (WLan AutoConfig)
  • BFE (Base Filtering Engine)
  • EventLog (Windows Event Log)

These Windows services are usually on by default unless you disabled them. If you find these services are running but GlassWire will still not run please consider running Windows Update. With very old versions of Windows GlassWire may not run properly. After updating your device please once again try a clean install with GlassWire in the order listed above.

Alll services, etc were running. Windows 10Pro - fully updated. Reboots did nothing.

But the uninstall, reboot, clean install worked - thank you!

I have a running GlassWire, looks great with dark theme as well :slight_smile:


I’m glad it’s working! I hope you enjoy the new themes.