Upgrading to GlassWire 2.0, tips, tricks, bug reports, feedback, and fixes


Hi there

May I ask a quick question about v2.0.80? If one unlocks Settings/Security & Settings/VirusTotal so that the relevant options are selectable, is it normal that when has exited Settings by clicking OK, when one next goes into Settings the same pages are once again showing as Locked?

Just wanted to check if this is a safety feature rather than what might appear to be a bug. I suspect the former but for the sake of clarity thought it best to ask the more learned of the Glasswire Forum. :star_struck:

Many thanks in advance.



So the free version of GlassWire 2.0 will not block any apps using the click-to-block system of 1.0? Am I understanding this correctly?


2 things happened at 1 time…Very confusing.
Windows update and your update…

All of a sudden my system monitor said I was using 30+% ALL THE TIME…
Did a little looking and found Win firewall connected to Coremessaging, then RPC…
TRIED fix/find/ do something, but Win-HOME SUCKS on trying to self fix.

Went to windows help and they TRIED…and DIED…(CANNED ASSISTANCE SUCKS)

Di a couple more searches and found a fix…START DEFENDER AND FIREWALL, and hit DEFAULT ON FIREWALL…RESET…TURN IT ALL OFF AGAIN, and RESET…

Are you using DEFENDER FIREWALL???
Because NOW, Connecting local service, Connection failed, Service STOPPED…

So, whats wrong??


It was working while most of this was going on, UNTIL I turned Defender Firewall OFF…



You said windows update and our update happened at one time? We have not alerted any 1.0 users to upgrade to 2.0 yet, and GlassWire has no ability to do an update itself so I’m not sure how it is possible.

Did you install our update in the moment the Windows update happened?

If you are having problems related to our firewall you can uninstall GlassWire in add/remove programs, then go to the Windows Firewall control panel, then choose “restore defaults”. You can then reinstall GlassWire using its clean install option. We use the Windows Firewall API, that’s correct.


I received a notice to update from your program.
It failed to install, while the Ver.1 was Running, so I killed the running version, then Ran 2,0,80…It installed then the problem started…

If this is running defender Firewall, Why do we need yours? Bells and whistles??
Im sorry, I dislike windows in the first place…Im old hat and been using comps since the 70’s… SEEN better and USED better… Only reason I use Win/tel is the games I like…and if they would revert BACK to how they USED to program the games…I would jump ship FAST.
If you folks are only creating bells and whistles, I’d rather gopt Majorgeeks and pick one up…With a Background and history.


GlassWire 2.0 says my activation code is not valid :frowning:
Please don’t tell me I have to buy a new one for 2.0??



I got your private message and replied. No, you don’t have to buy a new one and this is pinned at the top of the forum for 1.0 users that GlassWire 2 is a free upgrade.


Sorry bout that, pulled the trigger a bit quickly there. Thanks for the support, it’s all good now :slight_smile:


@Ken_GlassWire is there any way where we can backup a profile and use it in other systems? I could not find anything conspicuous. Is it the client.conf file?


@god here is how to move the GlassWire Database with your data stats https://www.glasswire.com/userguide/#Moving_Database but I think it will not move your firewall profile.

We should add that as an option in the future, to save and export profiles/firewall rules.


Thank you for the reply @Ken_GlassWire

I have read that, but I was not sure if it would move the firewall rules. If it doesn’t then, it wouldnt be of use to me.


The issue with Nord VPN is back and it’s no longer possible to fix it with conf file edit since it’s encoded



If you move the config file to your desktop, then quit GlassWire and its service, then add the required Nord line, then drag it back and restart GlassWire and its service, it does not work? I still see this config file for the beta so perhaps I’m misunderstanding something?


I did just that and the internet dies as soon as I connect to Nord VPN. This is the content of my

C:\Users\foobar\AppData\Local\GlassWire\client\client.conf file

the Nord VPN line got either scrambled, or removed after I restarted my PC.


You’re just looking to wrong place. You need C:\ProgramData\GlassWire\service\glasswire.conf


I have the same problem…



If you use C:\ProgramData\GlassWire\service\glasswire.conf does it work?



Hello Ken, Thanks for the reply but I don’t know what you mean by that.
"If you use C:\ProgramData\GlassWire\service\glasswire.conf does it work?"
Do I have to ad some code or something?
If I open the glassire conf. it says:

Let me know what I have to do…



Sorry, I think I mixed you up with another customer who had a NordVPN problem.

Inside the GlassWire.conf text file created by Notepad please insert this text.

hostname_enable_nslookup = false

Please move the .conf file to C:\programdata\GlassWire\service

Reboot your PC.

Now the problem should be fixed.