USB Keyboard & Mouse Disconnects


I have been going through various problems with Glasswire. Initially, just slow startup times and large dump files on the desktop w/ 1.2.96. I provided the dumps and decided to remove the application for a while and wait. I also had issues with NordVPN (with both the NordVPN and OpenVPN clients). Support had me reinstall and try and gather more data. No dumps as of yet, but I used the system very sparingly. I did notices something odd when I did. My USB keyboard and mouse would disconnect and not reconnect. I tried all the Windows troubleshooting changes to the USB hubs and disabling USB selective suspend settings. It would still disconnect the keyboard and mouse and not allow me to reconnect even if moving ports. I finally decided to remove Glasswire again. It has not happened since. Not sure what is conflicting here and wondering if anyone else has encountered it or has any other suggestions.



Sorry for the problem. I have never seen this reported before in the forum or to the helpdesk.

If you can recreate the problem please give us details about your setup and we can try and recreate and fix it. You are welcome to email the details if you don’t want to post them here to the public.

For the DMP problems we have found the issue and a fix will be out soon.


System is pretty basic. i7-7700K w/ GA-Z270X-Gaming 7 (F4 BIOS), 32GB (16x2) of G.SKILL Trident Z RAM (passed Memtest+). 1TB Intel M.2 nvme drive (600P, installed latest firmware). Have an ADATA SU900 512GB drive for a scratch drive for my photography/Adobe Lightroom work, and a 3TB Hitachi UltraStar HDD for initial storage. Video card is an nVidia 1070 FE with the latest drivers. Also have an LG BD Optical drive. Plenty of power for the system 750w PSU and all system temps are fine (no overclocking at this point).

I have Malwarebytes Premium running as well as BitDefender Antivirus Plus 2017 running. Also used 1Password (come over from macOS). CCleaner is running at startup as well as my Brother network printer startup software. Also running in the background is the Sound Blaster Recon3Di control panel and the Corsair link monitoring the AOI liquid cooler temps. A budget photo editing and general use workstation; not a PC gamer. Running Windows 10 Pro.

Got a bunch of photo work to do at the moment (editing) so I will not be putting Glasswire back on for a while and I need the system to be stable and cannot risk losing edits when my mouse and keyboard (and wondering if all USB ports, may have to pay attention to the light on my CF/SD card reader).

Let me know if there is anything else you want me to add. At first I was not sure if this was caused by the last patch Tuesday or not, but since the system has been stable since I removed Glasswire, I ruled that out for my use case.


This isn’t as mysterious as is supposed , its a long standing problem with some updates and systems using Windows dating back to Win 7 and is related to non-recognition of the digital signature of the usb drivers even though they were recognized previously . Have a look at : while it might not give all the definitive answers it will certainly point in the direction of this fault.


Page not found on the link…


… I did find some similar documents searching. I have the latest (from Intel) chipset drivers for the 200 series chipset. As I stated have not had the issue again since I removed Glasswire. I’ve read they have issues with some soundboard drivers conflicting, perhaps the new Z270 chipset and Kaby Lake CPU’s introduce issues for Glasswire at the moment too.


Sorry about that Sith Tracy I didn’t use a normal search engine to get it but a special secure German one but I don’t see how it cant be obtained if you input - keyboard and mouse not working since windows update that should give you a choice , its dated January 18-2014 and has had 81,008 views it wasn’t answered by the Microsoft MVP but by posters who gave comprehensive answers and they worked -194 people had the same question so it isn’t rare and thats on MS,s official website. I tried another browser it gave me a selection of websites to click on - funnily enough not the same one as I posted which gave a tick up for the correct answer.


Do own a usb power meter, they’re cheap … you might have a voltage and amp issues ? are the USB port’s 3.0 or 2.0., 2.0 can only use .500 amps ., if something is required to use more amp’s , you will need usb 3.0…

There are others., just showing you this one., with usb meter , you can connect your mouse or keyboard

I would also make sure your winpcap is at 4.13., you just need one copy is needed., other program love to install there version of winpcap . And yes that would cause network issues, winpcap mirror’s your network traffic