Using Software on Win Server - Google Compute

Somehow when I install your software on a Windows 2012 R2 instance on Google Compute the service won’t start.

If I reboot the server, it won’t even boot back up!!!

It works fine on my bare metal 2012 server here @ the office.

Don’t know if it’s an R2 issue, or an issue with the Google Compute Instance.

Either way, would be nice if it worked :frowning:

Thanks, Matt

Sorry for the problem. Do you use any third part security software that’s different on that other server that could be blocking our service from starting?

Have you run all recent Windows updates on that server? That might help also in some cases.

It’s a completely clean Windows Server 2012 R2 installation, no software at all installed, and nothing shows up in the event logs either, it just says “can’t start service”

Is it up to date with the latest Microsoft service packs, or are you saying it’s totally clean and it has never been updated at all?

Well it was totally clean, and I’ve since done the windows updates, but if I try to install Glasswire again, it will likely brick the VM again, and I’d have to reload it from scratch again.

I just bought the Elite License of Glasswire, so perhaps you guys could spend a few dollars on a Google Compute Instance and see if you can replicate/resolve?

glasswire --=at=- was the e-mail used.

Any news on this? I’d really like to put Glasswire on this Windows Server 2012 R2 instance.


Reported to support team, sorry for the delay.

@ErkDog We made a special version of GlassWire for you to test. Can you email our helpdesk with a link to this thread?

I’ve Done this, thanks.

1 Like


The problem is caused by custom drivers installed by Google to their server instances. Here are the instructions to make GlassWire work on a Google compute server instance.

  1. Run regedit.exe and open the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e972-e325-11ce-bfc1-08002be10318}\0010

  2. Change the value of *RscIPv4 to 0

  3. Change the value of *RscIPv6 to 0

  4. Reboot the server

  5. Install GlassWire

Please let us know your results.

I do not have the key you have referenced:

Please advise.

Wait I found it, it’s 0010

Ken looks like your copy/paste added #'s to the end of things on the numbered list.

The e-mail I got says 0010 and to change the keys to 0 and 0 not 03 and 04.


Please let me know if the instructions in the email worked, then once you confirm I’ll update this post. I’m not sure why Discourse changes the numbers… sorry.

it works it works it works !!!

1 Like

Great! I fixed the post above. Discourse tries to auto-number numbers in posts, very annoying!