Virtual servers crashing after installing Glasswire


#1

Hi,
After installing Glasswire 1.2.7.4 on two servers, one 2008R2 with latest updates and service packs and one 2012 R2 with latest updates and service packs, these servers crash periodically (up to twice a day).
Please assist
thanks
James


#2

@gostega

Sorry for the problem. First go to the top left GlassWire menu and choose “deactivate” if you use a paid version to release the license. Next please go to add/remove programs and uninstall GlassWire, reboot if it’s convenient, then reinstall our latest version using the “clean” option.

Please let me know if 1.2.76 solves the problem or not.

Also if you have any .dmp files on the desktop please email them to us if this continues with .76. https://www.glasswire.com/contact/


#3

Hi Ken,
Thanks for your reply. I’ve done that and will report back.
Regards
James


#4

Hi Ken,
Sorry, I realised I actually had 1.2.76 installed on the 2nd server already (2012 R2).
Regards
James


#5

@gostega

Is there any updates regarding the topic? I have plans to start using Glasswire on my Windows Server 2012 R2.

Does your server still crashing?


#6

@repou

I recommend trying GlassWire on your own servers. Our QA has tested with Windows Server 2012 R2 and found no problems.


#7

@repou @Ken_GlassWire
Hi repou,
Yes it still is, I have installed it on 3 servers now (2008R2 x2, 2012R2) and makes all of them crash.
These are all virtual machines running on Hyper-V 2012R2 with latest patches on hosts, latest integration tools in guests.
I’m still waiting for an update from Glasswire.
no .dmp files in %systemroot% after crashes. I also unticked “restart automatically after crash” on the 2012R2 server but it did not have any effect.
the tool “bluescreenview” does not detect any BSOD events. So I suspect it is not a BSOD but some other sort of crash.
latest was 1hr ago on the 2012R2 server (showing 57mins uptime).
I have uninstalled Glasswire 1.2.76 on all servers since I can’t have these crashing anymore.
regards
James


#8

@gostega

Do you see any .dmp files on the desktop or anywhere else? That would help us diagnose and fix the problem for you.


#9

Hi Ken,
None on the desktop either. I searched the entire C: drive for *.dmp and could not find anything.
Thanks
James


#10

Hi Ken,
Any updates on this? If this evaluation succeeds I will be looking into purchasing Glasswire for a few servers but no chance of that right now.
Regards
James


#11

@gostega

Is your server on AWS or hosted somewhere else? The reason I ask is because another user had a similar problem on AWS that we were able to figure out.


#12

Hi Ken,
No not on AWS. My own Hyper-V hosts. Happens on both 2008R2 and 2012R2 hosts, and both 2008R2 and 2012R2 guest VMs as well.
Really hoping for a solution to this
James


#13

Hi Guys,
I am having the same problem with version 2.0.
I’m running HyperV on Server 2008 R2 with a Server 2008 R2 Client VM.
I just installed the trial this morning and within 2 hours the server hung.
I wouldn’t say it crashed it just hung with a black console screen and was completely unresponsive.
Nothing to do by power off the VM.
I have disabled the service and unless there is a clear solution fairly quickly I’ll be uninstalling my trial.
David


#14

@David_Pollard

Did you get any .dmp files to your desktop? If so could you email them to us?
https://www.glasswire.com/contact/


#15

Hi Ken,
No, there are no .dmp files anywhere. As I mentioned I think the OS was hung not crashed.
I could not even ping it. If it helps any the primary function of this server is SQL 2008 R2 Database Server.
I installed on a test server first which does not have much load. It has been running for 24 hours with no problem. The test server is a VM using the same OS with on the same HyperV Server.

This is a primary business server so I can’t kill it to help diagnose the problem.
It’s a shame as it looks like this program will help me diagnose my network usage problems.

Hope this information helps.
David


#16

@David_Pollard

We had another customer with a similar problem and he ran the latest Windows updates with his server and it solved the problem. But of course in some situations this is difficult to do with a primary business server.

We will test and try to reproduce/fix this. Thanks for your detailed report.


#17

Hi Ken,
My updates are within a month of being current so I’m curious how long ago this solved it for your other user.
I’ll schedule a new round of updates for this server soon.

However as you indicated, without a clear solution it’s a big risk for me to test on a production server.
I’ll continue to monitor this thread and let me know if you find the cause.

Thanks
David