VirusTotal check on 'GlassWire Control Service' shows 'Analysis Failed'

Whenever ‘GlassWire Control Service’ is analyzed by VirusTotal (whether manually by clicking the ‘Analyze’ button, or automatically when it initiates network activity), the result is always the same: Analysis Failed.

Why can’t GlassWire submit itself for analysis by VirusTotal?

Everything else in the list on my Firewall tab could be analyzed successfully.

I’m running the latest version: v2.0.112.

1 Like


I just tried to analyze the GlassWire control service and it just failed for me also.

We know our customers would be very angry they can’t analyze parts of GlassWire itself, and we have always also allowed GlassWire to analyze itself, and even block itself with its own firewall. This is not intentional and I’ll report this and see if others on our team can also reproduce this so it can be solved ASAP.


This morning it’s working fine, can you try again? Maybe VT was having a temporary problem with their service.

Yes, it worked today. But it came back with the result immediately, which means it was relying on VirusTotal having already analyzed that particular file. Yesterday GlassWire was likely trying (unsuccessfully) to upload the file (i.e. not relying on a cached result from an already-analyzed file) and that process failed. I bet that is the difference.

I can confirm we have made no changes recently to the VirusTotal API and how it works with GlassWire, so any anomalies are probably not related to GlassWire itself. However we’ll keep investigating and see if we can reproduce this.