Windows Firewall gives notification instead of GlassWire

Hello everyone,

I am a relatively new user to this program and maybe i understood something the wrong way. But i thought GlassWire is supposed to control the Windows firewall and replace those annoying native notifications with nice subtle ones in the corner of your screen.

Now this works great for most programs, but for some (like Spotify or most games) it still displays the native Windows firewall dialog first. After a minute or so it displays the GW notification too. In general, for some connections, there is a delay until GW displays the ask to connect notification.

As far as I can tell this is only the case on my PC and only with incoming connections, because otherwise Windows does not give the dialog anyways.
I could imagine it happens because I also use Kaspersky here, but the firewall there is disabled in the settings.

I have tried uninstalling, resetting Windows firewall to default, restarting PC and reinstalling with clean settings.

Thanks in advance,


GlassWire should give one “Ask to connect” notification that looks like this.


If you are seeing a notification from Windows Firewall itself then something is definitely wrong. If I had to guess I’d think that perhaps you tried another firewall app in the past, and perhaps that app left some weird rules with the Windows Firewall API.

Kaspersky should make no difference with what you’re seeing.

To solve the issue please try this:

Uninstall GlassWire in add/remove programs.

Go to the Windows Firewall control panel and choose “restore defaults”.


Install GlassWire again and choose the “reset firewall” option.

Now try our “Ask to connect” mode and see if it’s working OK.

I am getting this exact notification, so that works great. But sometimes it only displays after I got the one from Windows.

I did do as you suggested, since that was posted in a similar topic here. So even after resetting everything it still happens. Maybe i should check manually for weird rules in the Windows firewall.


Would it be possible to email me a link to this thread along with some screenshots next time this happens?

We can then provide instructions on how to create logs. Once that is done we can figure out how to reproduce this and fix it if it’s a bug.


After the issue happens again and you email us a screenshot, then please turn on logging AFTER it happens again.

Our team said if you would turn on logging and recreate the issue then it might help us find the problem.

How do I turn on logging?

  • Stop the GlassWire service with the task manager under “services”.

  • Open the file: C:\ProgramData\GlassWire\service\glasswire.conf as administrator with Notepad.

  • Set parameter LogEnabled to “true” and save changes.

  • Start the GlassWire service again by right clicking under the task manager and services.

When the issue shows up again please send us the logs from C:\ProgramData\GlassWire\service\log as soon as the issue is reproduced.