With 1.2.79 can't connect to remote server (solved)

When I installed the 1.2.79 Elite on my computer1, I can’t connect to my other computer2 running also 1.2.79 Elite

When I install the older 1.2.74 on my computer1, Glasswire connects immediately to computer2 without any change on both computers, so I think, my setting (firewall etc) are ok.

Both computers are in the same subnetwork.

Your Remote PC:

  1. First go to the top left GlassWire menu and open settings\server\remote access;
  2. Check the box “Allow remote access by password”;
  3. Click “Change password” and set the new password. Try making the password simple for the first connection only, to be sure you don’t have a typo.
  4. Click OK;
  5. Open settings\server\general and make sure that the “Remote access state” is “Allowed”

Local PC (the PC from which we are going to connect to the remote PC from):

  1. Open Settings\Client\Remote server;
  2. Click “Add new server” and select it on the “Server list”;
  3. Type the name of the server;
  4. Type the IP address of the remote server; Go to www.whatismyip.com5 from the remote server if you’re not sure.
  5. Type the remote server password, which was set previously;
  6. Check “Enable connection”;
  7. Click OK.The connection process should start. If the connection was successful please use a secure password, or limit connections from a certain IP address.

Did the connection fail? What is the error message you see when the connection fails? Are you 100% sure the local and remote versions of GlassWire both use our latest software versions?

I have tried this without success, Glasswire shows counting up the connect retrys and than shows the error Can’t connect (in german: Verbindung kann nicht hergestellt werden)

What I found out: TCPView shows with the old Glasswire a connection to my computer2 on port 7007, the 1.2.79 tries to connect on port 7010.

Both Glasswires are 100% the same versions, because I use the same Installer EXE.

Please try entering the port number after the IP, like :7007 if that’s the one you need. Sorry for any confusion.

OK, fine, that :7007 was now the solution, but I am a little confused, because I don’t have set any manual port settings on both computers in the past for Glasswire.

Why is 1.2.79 suddenly searching on port 7010 and not as the old version on port 7007?

The settings at Server/General are with both (old and new) the same: 7007 Standardserver - 7000 Start Portrange - 8000 End Portrange.


We changed the ports https://www.glasswire.com/changes/ because some antimalware software thought the old port used could be malware, and it would give false warnings.

Ok, that have I not read intent enough, sorry. Thanks for your fast help.