1.2.73 Installation Failure

When I try to upgrade to 1.2.73, I get an error during the Setup: “Error opening file for writing: C:\Program Files(x86)\GlassWire\GWCtlSrv.exe”. If I click “Ignore” in the dialog box, I get the same error for the next file to be installed. This is on Windows 10.0.10586 under Bootcamp on a Mac Mini i5-4278U 2.6GHz machine.

Prior updates have run with no problem. Any help would be most appreciated.

Does right clicking the installer and choosing “run as administrator” help? I have not seen this before so I’ll discuss some other ideas with the development team.

If you uninstall the older version in add/remove programs does it work?

Do you use any unusual third party utilities or any unusual security software?

I’ve tried running the installer as admin, but I get the same error. I’ve tried running the installer after exiting the current version, with no luck. I’m hesitant to uninstall the current version for two reasons; first, if the installer doesn’t work then I’m left with no firewall, and second I’d rather not lose the app connection permissions I’ve built up over time.

@jeverett Please try to kill GwCtlSrv.exe in the Task manager and reinstall GlassWire.

Success: I stopped the GlassWire Control Service in the Windows Task Manager, which has to be run as admin. I then killed the Glasswire process and was able to do the installation. This is the first update that has required this additional step; prior updates just worked directly, without having to quit GlassWire or stop the service.

1 Like