1.2.79 High Memory Usage

I don’t know if anyone else is experiencing this but my free version of 1.2.79 started using 1.3 gigs of memory after my install.

After updating from 1.2.74 to 1.2.79 Glasswire’s memory usage shot up to 1.3 gigs. I then tried a fresh install of 1.2.79 and it was still reporting 1.3 gigs of memory used. Downgrading back to 1.2.74 with an old installer now puts me 40 mb used. Anyone have any suggestions?


Thank you for your report. How many devices do you see under your “network” tab? Do you use Bittorrent software? Has any of your computer use behavior changed after the update, for example did you start using Bittorrent heavily?

How many devices as in how many times Glasswire shows up under my task manager? Currently in 1.2.74 I see 3. And no I did not start using anything like Bittorrent while running 1.2.74 or 1.2.79. I pretty much only had chrome open with 2-3 tabs open searching the forums. Steam was also open but nothing was being downloaded at the time. I even tried a restart of my computer and the same thing was happening with the high memory usage until I downgraded.

Edit: For devices under “Network” of glasswire it says 1 device is currently detected on your network.

Please try an uninstall, reboot, then reinstall our current version with the “clean” option, then email us a link to this thread if your memory goes up again if you will help us find and fix this permanently.


Yeah, same problem. Should I be emailing your “help” or “bugs” email?


Either is fine, thanks.