A problem then another problem

Hello
I had the problem described in the following topic today:

" [Service host using lots of CPU"

(I have Glasswire Pro on my Windows desktop. Every week or so, a process called “Service Host: Local Service (No Network) (3)” will begin using tons of CPU time. Windows Defender Firewall is one of its three sub-processes, which is why I suspected GlassWire. Sure enough, when I kill the GlassWire Control Service, the process stops using CPU. I have also been able to stop the process by resetting Windows Firewall to default settings, but I do not want to do that every week.)

I have also tried reinstalling GlassWire. Does anyone have any suggestions?
I followed the instructions (2 times to get it to work) and now I have what is described here in number 1

" [Lot of problem with Firewall on GlassWire 2.0]"

(choice for firewall type is grayed out: no way to switch between “click to block” / “Ask to connect” / “Block all”…)

this time however, the solution suggested in the topic is not working. Uninstalling and installing again doesn’t fix the problem
I am using the latest version (pro) on windows 10

PS Sorry for using topic headlines, I tried to use the links but as a new member I am not allowed to

@Hastur

What firewall mode are you in with GlassWire? Is it “Ask to connect”? Or I guess you cannot use any mode and it’s off, yet you still have this issue?

I see uninstall/reinstalling doesn’t solve it, but I would suggest this exact order of operations:

  1. Go to add/remove programs and uninstall GlassWire.
  2. Go to Windows Firewall control panel and choose “restore defaults”.
  3. Reboot - IMPORTANT
  4. Download our latest software. Choose “clean install” and “reset firewall” options.

Can you switch on the firewall now? Are you paid or free?

I did all of that but the problem persists. I have pro as I stated earlier.

I can’t see what mode the firewall is in now as you say. Usually I prefer “ask to connect”

should I update windows to 1909? Could it help? I usually delay the latest feature update to avoid possible bugs. Everything else on the windows update is however updated.

Since it doesn’t ask me to connect (I see the notifications of the “new” programs connecting), it should be on “click to block” mode

@Hastur

Are you using another firewall simultaneously? Yes, I think it can’t hurt to try a Windows Update, then start over and follow those reinstall instructions.

It sounds like something is conflicting with our use of the Windows Firewall API. Any idea what it could be?

I don’t use any other firewall. I do use Kaspersky free AV though. It recently changed, maybe it could be doing that. I will experiment with it after doing windows update tomorrow.

@Hastur

I found this screenshot. You may need to disable the Kaspersky firewall to use the Windows Firewall API. It depends which version of Kaspersky you are using though.

Hello there
First of all, without any offence I think you should know the difference between antivirus and “internet security”. you can google it, I will copy and paste a short answer from the web:

Best answer: Both antivirus and internet security programs protect your computer from malware, especially files attempting to download from online, but differ in terms of features. Internet security programs include additional security tools to keep your whole computer safe, including a firewall, password manager, and vulnerability scanners. However, for the ultimate protection package, a premium security suite is the way to go.

My Kaspersky was the free AV (antivirus) Your screenshot was from the internet security (which contains firewall)
Having said that, the latest version of Kaspersky had some modules that seemed suspicious to me (that could be interfering with the firewall). In the free version you cant turn them on and off so I went on and UNINSTALLED the whole damn thing :slight_smile:

I also updated my windows as I said last night

I took the steps you mentioned to install glasswire again:

I would suggest this exact order of operations:

1. Go to add/remove programs and uninstall GlassWire.
2. Go to Windows Firewall control panel and choose “restore defaults”.
3. Reboot - IMPORTANT
4. Download our latest software. Choose “clean install” and “reset firewall” options

But the problem still remains unfortunately…

any other suggestions?

I got it fixed finally. I deleted some registry entries (after backing up of course) and reinstalled again. Now it’s as its supposed to be.

Hi Hastur
I am curious, what registry keys did you delete. Where they part of Kaspersky AV?

Hi, I am having the same situation as you. Do not know you have solved it yet?

Hello
I admit I don’t know what I am doing when deleting registry entries. I know it’s risky, but still… so using a registry editor tool I backed up first and then deleted most kasperksy AND glasswire entries. It would be too time consuming to check what every line is supposed to do.

I fixed it by messing with the registry. You must be aware that by doing that you are at a risk of damaging the operating system. I will not be held responsible for that. Please try the other steps mentioned in this threat first. Also, are you sure you have exactly the same problem as me? You cant change mode in the taskbar icon but how about in the main interface? Is the firewall just turned off maybe? did you check?

on

Try first there to see if you can click to turn it on and then change mode

I know nothing about Kaspersky, but randomly deleting GlassWire registry entries should not help with any GlassWire issues in any way. We offer several options to clear our settings to the default inside our application so it’s not necessary to do something like that.