Activation lost while GlassWire is running

I used the Things scan yesterday. Today, I cannot use the Things scan because GlassWire has lost it’s activation without me deactivating, restarting GlassWire or restarting Windows.

The processes have not been restarted for nearly a week:
GlassWire.exe since 11-10-2018 04:08:20
GWCtlSrv.exe since 11-10-2018 04:04:31

I was using the Things scan to confirm that a network printer had IP address I had assigned it at the router for DHCP.

The UI was not opened between the two Things scans. The only other activity I did in GlassWire was to clear the alerts.

My system details are:

GlassWire version

Windows 10 Home
Version 1809
Installed 5/10/2018
OS Build 17763.55

1 Like


Sorry for the problem.

We had some people who had this problem before with one version of GlassWire, along with people who upgraded from that version. Doing a clean install solved the issue by fixing the bug with that problem.

Other people who had this problem used some kind of cleaning software that cleaned the programdata/glasswire folder and would delete some of our files.

I mention both of these things for other users who may find this thread, but I realize you are an advanced user so perhaps neither one of these things apply to you.

I will ask our QA to test with your Windows version and we’ll try to recreate this on our end. Thanks for your detailed report.

I have had deactivations occur before on several earlier versions of GlassWire. This is the first time, I’ve actually known when the deactivation has occurred.

I do use Piriform CCleaner for file cleanup but I have not used it since well before these processes were loaded.

The following may help you to pinpoint where the issue is occuring:

Don’t rely on this, but I thought that GlassWire was still activated when I first opened the window this morning. I can’t be certain about this but I thought that the green Activate button was not visible when the window first opened.

I’m definitely certain that the latest alerts that appeared in the GlassWire were “Internet access changed” and “Idle time”. Less than a minute later when I returned from the Things tab, all the alerts had disappeared back to 23 July 2018 but new “VirusTotal scan result” alerts had appeared. They have only reappeared now that I have reactivated.

P.S. I just deactivated and reactivated and the Alert tab does not display this behaviour because a manual deactivation forces an immediate restart of GlassWire.

P.P.S. Fortuitously, I took a screen shot of the Alert tab because it was the view was unusual:

P.P.P.S. And here is what it looks like on reactivation:

We had some customers who would travel around parts of Asia and would have connectivity issues. We worked with them and sent them special logging versions of GlassWire that helped us re-design our activation system so it’s very reliable, even in countries with connectivity problems with the US.

If this problem continues let me know in a private message and I can help you do this extreme testing like we did with those customers and we should be able to find the exact issue, and solve it.

Again, I apologize for the issue and we have spent a lot of time trying to help people ever experience this problem. It’s a very bad experience to become deactivated from something you purchased. We don’t want this situation to happen to anyone.

Thanks for the screenshots and detailed info! I’ll send the link to our team who worked on the activation issues before with some other customers in unique situations.

Pues CCleaner no creo que sea el problema. Yo lo suelo utilizar muy seguido y no tengo ningún problema con GlassWire.

Como podrás notar en la imagen.

Soy una persona la cual le gusta modificar demasiado windows 10, tanto los registros, el algoritmo, etc. A lo que quiero llegar es que yo suelo modificar el registro (incluso restaurarlo a su estado original), eso y otras cosas mas y nunca e tenido problema con GlassWire, ni con otros programas que utilizo. Nadie debería de tenerlos, por mientras sepas lo que haces. También me dedico a rempaquetar los programas, modificar cosas, quitarles cosas,etc. Claro algunas programas es fácil hacer ciertas cosas y en otras te puede llevar muchísimo tiempo.

YA NO ES NECESARIO LEER ESTO A CONTINUACIÓN, solo son opiniones y cosas que tal vez podria hacer por la comunidad


No e visto a nadie que diga como hacerlo o si se puede hacer. Yo la verdad creo que sI de puede (estoy seguro un 85% que si) y puedo intentarlo si bastante gente lo desea (ya que lleva tiempo). Ya que en muchos programas lo hago (dejarlos como los tenia).

Yo recientemente tuve un problema y tuve que reinstalar el programa pero no me importo perder algunas cosas del programa. Pero estoy seguro que otros no quisieran perderías, por lo tanto creo que no tan solo haciendo una copia donde se encuentra instalado GlassWire sea una solución para recuperar los ajustes y demás que tenias (Puede ser que si lo haces si funcione, algunos programas no suelen ser tan complejos o difíciles, solo es cuestión de probar. PERO NO TE ASEGURO NADA). Hay mas archivos en otras partes del programa que tal vez también seria hacerles copias y luego volver a ponerlas para no perder cierta información importante, pero claro esto tiene su desventaja y es que si hay un error critico que le sucedió al programa tal vez no lo puedas hacer del todo esto que digo.

No e entrado a fondo en todos los “archivos” del programa para saber cual es la mejor manera de poder recuperar todos los ajustes. Pero de que hay una la hay.

Por ultimo quiero decir que aunque se pueda recuperar los archivos no es algo que recomendaría de hacer del todo, ya que suelen traer aveces inestabilidad y mas si el programa se actualizo.