Android firewall don't activate

I just updated my GlassWire on android phone to try new firewall feature. I clicked the firewall tab and the OFF-button. It opened a new windows with 4 feature slides and green box at the bottom. There is circle running on the box and nothing else happens. I’ve tried to reboot the device and give it few hours time to run the circle but nothing happens. I also tried to click ‘upgrade’ menu entry and got the same window with same result. I also tried to send feedback using built-in feature but it didn’t work either, just popped a new menu to ‘select sharing method’ and list of some apps installed on my device (none of those worked). My android is 6.0 on Sony device.


Let’s get this fixed for you!

Please try to turn on the firewall, then when it fails please go to the top left three line GlassWire menu and choose “send feedback” and let us know what is happening. We can then solve the issue.

Do you use another VPN simultaneously while trying to use our firewall?

As I tried to explain above, I already tried this but here are screenshots how It looks on my device. I write the feedback and click the arrow on the upper right corner to send it, I got the popup shown in 3rd pic. Its in finnish, sorry about that, but it translates rougly ‘select sharing method or share in app:’ and I tried all of them but none of them worked.

I think I don’t have any VPN or other firewall and the phone is not rooted. I have Sophos AV installed. I have wi-fi and mobile-data enabled.

I’m sorry I missed the part about our feedback system failing. I’ll ask our team and see if they have some ideas.


I discussed this with our team.

Both of the items you are having trouble with use the Google Android default APIs, or Google Play store API. Are you using another firewall that blocks any parts of the Android OS? If you unblock them does it solve the issue?

Our app itself uses no network activity, but the “send feedback” feature comes from the Android OS, and the “Trial” through Google Play also comes from Google Play, not our app. So you should allow your OS to access the network to try our trial, or to “send feedback”.