Ask to connect acting weird

Hi all

I’ve just reinstalled windows and glasswire pro (latest version ofcourse), and I’m having trouble with the ask to connect feature. It seems to work for certain programs, but not for all of them. Here’s the issue I’m facing:

  • I launch Teamspeak 3 (for example, same thing happens with Steam and ShareX)
  • Glasswire asks to allow or deny, I press allow.
  • Teamspeak is unable to connect (even after restarting the program, rebooting, …)

Teamspeak is not blocked in glasswire or any other software. It works when I put the firewall in ‘Click to Block’ mode, but when I switch to ‘Ask to connect’ it disconnects. I’ve tried rebooting, reinstalling, and deleting the Glasswire folder in ProgramData. I did not face this issue on my previous windows install, but I do on my fresh one. I temporarily solved the issue by creating my own rule in windows firewall.

Any help would be appreciated,

Thanks in advance


i7 4770K
GTX 780
Intel onboard LAN, 1gbps link.
No other software messing with windows firewall.

Please go to the top left GlassWire menu and go to the “About” option and let me know what version of GlassWire you’re using. Sorry for the problem.

Glasswire Pro Version 1.2.54b

If you install GlassWIre again and check the box “clean install” does it solve the problem? Also please keep in mind this will delete your data and you’ll have to activate your paid version again.

Go to the top left GlassWire menu and choose “deactivate” before trying this method if possible. Sorry for the hassle.

Do you use any other third party software that interacts with the Windows Firewall?

I’ve already done that twice, and I do not have any other software that interacts with windows firewall.

OK. I recommend completely uninstalling GlassWire, then rebooting, then go to “Search Windows” and type in “Windows Firewall” then open “Windows Firewall” and click “Restore Defaults” on the right side, then reboot, then do yet another clean install of GlassWire using the clean install option with the installer.

Please let me know if that solves the problem.

I’ve already did that, but I ran this command instead of manually going to reset the firewall: “netsh advfirewall reset”. I’ll try it anyway, one moment.

1 Like

The issue still presists after doing the steps you provided. It only seems to cause issue with certain programs. When I put it in ask to connect mode, Teamspeak 3, Steam (and the steam webhelper process) and ShareX can’t connect to the internet, whilst other programs work fine.

I’ll discuss with our development team and see what they recommend. Could you also email our helpdesk? We may want you to test a custom version.

I’m sending the e-mail right now. Is there anything I can do in the meantime? Any logs I can provide?

I got your email, thanks. I should have more info tomorrow, sorry for the delay.

@Vince We’re having trouble recreating this.

What exactly is not working on Steam? Are you able to connect? Or is the connection established successfully but some Steam features aren’t working? We want to be sure we understand.

1 Like

Taking Steam as an example:

Steam Client Bootstrapper and Steam Client WebHelper show up on the firewall, and neither are blocked.
Once I put the firewall in ask to connect mode, I can’t access the steam store. (So I think steam webhelper is being blocked, although it’s not in Glasswire.)

Same thing for Teamspeak 3;

Teamspeak 3 Client shows up in the glasswire firewall, not blocked. Once I put the firewall in ask to connect mode, teamspeak disconnects from the server I’m on.

Putting the firewall in click to block mode makes everything work though.