Bandwidth Speed Units

First of all, GlassWire doesn’t actually show speed units description. Is it Mbit/s or Mbyte/s ?
In the Settings under General tab, Bandwidth Speed Units only switches to Mbyte/s for the Mini Viewer. But the main Graph still displays Mbit/s. I hope this will be fixed soon.


If you go to our top left menu and choose “about”, what version of GlassWire do you use?

2.3.343, I know it worked at some point, but when I switched to Bits, then it wouldn’t go back, no matter what version I install.

Perhaps there is a misunderstanding.

MB is for mega Bytes, while Mb is for mega bits. I checked the settings and it seems to work with no issues.

Well I have a 200/200 Mbit/s connection from my internet provider. And I ran a speed test to ensure to get the correct numbers for this test. The first image shows the MB/s on Mini graph viewer and tells me that it is MB on the main graph, yet shows me Mb instead. Doesn’t matter if I even restart the program, it’s the same. And on the second image shows Mb on the Mini viewer, yet on the main graph it still tells me that it’s MB and yet shows me Mb. Does this look right? No, by no accounts!

GlassWire is showing your data usage over a 5 minute period while is doing a Speed Test that’s live. I believe that’s why there is a discrepancy. GlassWire is not a Speedtest tool.

Sorry for any confusion and thanks for your report.

Ahh, right. That makes sense. Because the spot that I have marked seems to be a 10 sec period. So 200 Mb/s / 8 bits = 25 MB/s * 10 sec = 250 MB/s. And that matches up with the data on the main graph. But that means that the data on the main graph always shows MB/s, no matter what Bandwidth Speed Units were chosen. Also I’ve only now realized that there is a slider underneath the main graph. So moving the slider, say from left to right, all the way to the right. Then every marked spot will be a 1sec period. So all of it can actually be used for speed test. On the image below I can see that my speedtest for a 200 Mb/s peaked at 27.5 MB/s while the average was at 24.7 MB/s . So indeed it works like it should. :slight_smile:

1 Like

I’m glad it’s working. Sorry for any confusion! Our historical data system is kind of unique so sometimes it can seem strange or wrong.