Beta test GlassWire for Android - Now with Zero-rated apps!


#1

Want to beta test new unreleased versions of GlassWire for Android with new features? It’s easy!

What’s new?

  • This new beta update has zero-rated apps. Go to your data plan, then scroll down to choose zero rated apps. Zero-rated apps are apps that don’t count against your data plan. This feature may not apply to you and your mobile provider but a lot of people have requested this feature.
  • Have you had incorrect data counting? Try this update and let us know if you run into any data counting problems.

IMPORTANT - If you find a bug please go to the top left GlassWire hamburger menu with the three lines, then tap it, then swipe down and choose “send feedback” with details on what’s wrong. This should send us some debug logs.

To start testing the GlassWire beta:

  1. Open this URL (on your Android device) and accept the invitation in the account that you use on your device: https://play.google.com/apps/testing/com.glasswire.android

  2. Install GlassWire from Google Play: https://play.google.com/store/apps/details?id=com.glasswire.android

  3. Send us the logs using the Feedback form in case you notice a bug (for example, incorrect data usage stats).

Ready to stop testing?
You can leave the program any time by going to the link for 1 above when you’re done testing. Trying this beta should not hurt your saved stats.

Don’t forget to send feedback!
Please test and give us your feedback and comments so we can improve. Leave comments here in this thread or choose “send feedback” inside the app to give us screenshots and debug logs.

Please note we can’t fix most bugs without the debug logs. Posting bugs here without logs won’t help us much.


#2

Finally got the beta test version to actually be the beta test version.

Yes, I can zero-rate apps. The only one it applies to is the MNO’s VoLTE offering, and I’ve yet to be in a situation where it applies (4G but no 3G).

Still not reporting tethering usage. But I think that’s an underlying android-on-wileyfox issue. It all worked fine when I had Cyanogen OS. Recent OTA update put me on Android 7.1.1 and tethering no longer shows. It no longer shows in settings->data either. I was hoping that glasswire had patched around an Android problem to get at tethering info, but it appears not. :frowning:


#3

@eehpcm

Thanks for your report, but we need logs badly.

Please use tethering while using GlassWire and make tethering use data (and confirm GlassWire does not show tethering), then go to the top left GlassWire hamburger menu and tap it, then swipe up and choose “send feedback” and send a screenshot and debug logs.

We can’t investigate without logs unfortunately.


#4

Feedback with logs just sent.

BTW, in “Set Data Plan->Set Usage” it would be nice if I could set it to say 9.8GB rather than having to calculate the value in MB. Although a decimal point is displayed on the keypad, it’s ignored.


#5

@eehpcm

I may be misunderstanding you but if you go to “My Plan” and tap “MB” under “Data Plan Limit” you can change it to GB from MB.


#6

Hi Ken

I didn’t express myself well.

My MNO’s usage app reports in GB. Right now it’s saying I’ve used 9.8GB. I can’t enter it as that because it doesn’t allow a decimal point. So I have to multiply by 1024 (or maybe only 1000, depending on which conversion factor the MNO uses), which requires extra work. Permitting the decimal point would be convenient.

But suppose that I’d installed glasswire towards the end of my billing period, when I had used, say, 24.4GB. I can’t enter that as 24986 MB (or maybe it’s 24400 MB) because the number can only have a maximum of 4 digits. So I have to use GB, round it down (in this case) to 24GB, and accept rounding errors amounting to over 1/3 of a day’s usage. Or always round up to ensure I get an alarm before I run out, which means a bigger error.


#7

Hi guys

Just updated to 1.0.61r. Did a power cycle after the update, then gave tethering a thorough workout (over 1G doing a full update on one computer tethered through wifi and watching youtube on another computer tethered by USB). Glasswire is still not showing any tethered usage.

Let me know if you want logs again.


Paul


#8

@eehpcm

Please do the following:

Start tethering on the phone;
Connect something to the phone using tethering;
Start using the internet on the connected device;
Disconnect;
Stop tethering;
Send us the logs with the “send feedback” option under the top left GlassWire hamburger menu.


#9

Hi Ken

Did all of that. Got an error message (from gmail or glasswire, not sure which) that it couldn’t attach an empty file, but looking at the sent mail there is a log file with 28k of gibberish attacked.

Good luck with it.


Paul


#10

Thank you. Sorry for the problem.


#11

The final version was released to the public. Thanks! https://blog.glasswire.com/2017/05/30/add-zero-rated-apps-for-your-mobile-data-plan/


#12

Please consider joining our beta testing group by following the instructions at the top of this thread, thanks!

We have a new version we’re testing now.