Blocks all on startup - off/on firewall needed

Always after starting Windows 10 , all Allowed apps are offline, being blocked. The only Windows App I allow is Edge and this one is able to connect. But Firefox not. I must go to Glasswire firewall tab and turn off and then turn on firewall to let non-windows apps go online. I use ‘Ask to connect’ mode.

my free version: 2.1.167


We use the Windows Firewall API. This allows GlassWire to continue to block even when it’s killed or not running.

If an app accesses the network before our user interface will start and if you’re in “Ask to connect” mode GlassWire may block something to protect you. We’re looking at adding a warning here inside GlassWire so if this happens you’ll get an alert about it instead of not knowing.

Is this something that’s happening every day or is it a bit rare? Perhaps Firefox is updating its version and this just happened a couple times but it won’t happen again since it only will happen during your bootup when GlassWire is not yet started, or maybe GlassWire isn’t running sometimes on your PC?

It happens everytime I bootup. Windows starts and I must manualy turn off and on firewall. Then allowed apps aren’t blocked anymore. There was nothing updated.

Also a question - I noticed in about tab that I have 4 days remaining, that means there is no free version of Glasswire ?


Are you using another firewall with GlassWire? It sounds like what you are experiencing is not how GlassWire works.

We have a free 7 day trial, then you’re downgraded to our free software that doesn’t have blocking features or our security monitoring features.

No, I use Glasswire only. And Windows Firewall I have set to block all out and in by default.

About free version - that means that, if I will not buy paid version, my Glasswire copy won’t be blocking apps anymore ?

1 Like


Yes, details are about different versions of GlassWire are here.

If you are having firewall issues please do this:

  1. Go to add/remove programs and uninstall Glasswire. Then go to the Windows Firewall control panel and choose “restore defaults”.
  2. Reboot - IMPORTANT
  3. Reinstall GlassWire using the “reset firewall” and “clean install” options.

Now switch on the firewall and use it normally.

Did all 3 steps. Still the same. Blocking apps after bootup. Turned off and on firewall and all is good again.

Ok, I think it can be difficult to track the issue here. Anyway, if in 3 days this free version is going to stop working maybe there is no sense to put more effort trying to find the solution.

Thank you, it’s really beautiful, I like the graphs and all the info it gives.


We’re preparing a major update that will be out shortly. You can get the beta by joining the email list here

It changes the firewall API a little bit, plus it also has an option for logging on your side that can allow us to find and fix bugs quickly.

Guys, I do not use GlassWire anymore, because my free time is gone :frowning: but I just came back here to let you know that my problem was probably not connected to your app. At the moment I am using “clean firewall” on windows 10 , which is a bit more time consuming but it is actually possible to block everything and unlock just those app I need to use online. Anyway, when I uninstalled GlassWire, I still had that problem with firewall OFF/ON each time after bootup. So I had to go to firewall setting, disable firewall and then enable it again. The issue was a Hyper-V virtual switch I had created before! There was some conflict, I didnt investigate it, but when I deleted this virtual switch and use default one, I dont have this firewall problem anymore. So now I am pretty sure that if I started using GlassWire again it would work flawlessly. It was strange because I wasn’t even using any virtual machines but still this configuariation reflected on system settings. I am just letting you know, because I feel like I created that issue and blamed your piece of software while actually I should blame Hyper-V from Windows 10.



Thank you for taking the time to let us know about this. We’ll try to recreate this on our end also.

Your post will help others in the future who may have this issue.

1 Like