Can't start GlassWire Service


Followed the instructions provided by @mitheshge to the letter (twice) but for 2.0.91 it does NOT work for me at all I am dead in the water, service is stopped and cannot be run, click restart service and it just say attempt 1, 2, 3 nothing!!! :frowning:

So I assume I have to wait for an update or lose my historical data?


It can be forced to start (or try and start up and it starts to display) monitor the service you can see it starting to increase memory usage and CPU usage, but then all of a sudden a second GWCTL process starts and the app fails out (loses connection to local server) and requires the service restarted, rise repeat over and over.

@Ken_GlassWire I am getting dump files but they are 250MB a piece so cant email them and didnlt see anything else on that page you linked.


@James_Fleming I had this issue in the 2.0.80 ver. and continued to use it until this update. When I installed 2.0.91, It worked super fine. Absolutely no issues. I restarted it at least 4 times at various intervals to make sure it worked alright. And it did until yesterday. The issue seems to be there even in this version @Ken_GlassWire . Again I tried my usual steps of Back up and Restore, clean install etc. Clean install works. But if I need my graphs back, its becoming a mess. And this time its not always. For ex. Yesterday I had this issue. I restarted a couple times to check. And It was not working. But now as I am writing this, my GW suddenly started fine during startup. And there are no dmp files on the desktop.
Any idea as to whats causing this?
@James_Fleming I do have the setup’s of the older versions just in case if you want them. But as Ken said, no point going back to the older versions as they have more issues.
2.0.80 has issues with windows defender blocking the firewall rules.
2.0.84 and 2.0.91 has the same issues - Doesn’t start up with system and service keeps crashing.
I have all three setup files if in case you need it.



Can you email us with a link to this thread?

I can send you some instructions on creating logs so we can investigate how this is possible, thanks.


@mitheshge Yes I finally gave up keeping the historical; data and just did the clean install.


It seems that the problem occurs when you restart the PC, but in some tests I did, if I turn off and restart, the program works well


Today I have .dmp in Desktop

Send to email


@miguelgrado Thanks, we got it and we’re investigating.


I have the same issue as the OP described since the last update.
I cannot uninstall Glasswire per the instructions as it no longer appears in the Windows Cpanel programs list even though the folder and exe are still on my system. I do have a third party uninstaller but have not used it.



Are you seeing any .dmp files on your desktop? If so can you email them to us?


Thanks for the reply. No, I do not have .dmp files on the desktop.



I also got this issue on atleast 50% on my reboots, for me it looks like it quit trying connect to early or something
since i randomly get it started when i push the connect button several times after i get the service has stopped msg.


Thanks. Some fans have emailed us some .dmp files and we think we found this problem. We’re working on an update that should be out soon.

Meanwhile, if you experience this problem and if you have a .dmp file on your desktop please email a link to this thread along with your.dmp file.


Same here. I do have the backup just in case GW starts working properly. But I clean installed. But now getting issues with clean install as well. :roll_eyes:



Please email our helpdesk with a link to this thread. I can then send you a new beta version to test that should solve this.

We really need your testing help, thanks!


New version seems to work well, tested on two PCs

New total Virus notifications very well.

One detail, the installer is 2,098, but the version of the program is 2,094 in about, but in Windows panel displays version 2,098



When you say new version, do you mean the beta I emailed to the testers or do you mean the version from our website? Thanks. I think you meant the beta judging from the description about the “About” problem but I wanted to be 100% sure.


Yes…is the version Beta emailed to testers today




I’m glad it’s working! Please let me know if you run into any problems with this beta.


For now, Two pcs all very Ok