Connection Popups are not On Top anymore

Dear all,

When running the firewall in “Ask To Connect” mode, a popup is generated on the bottom right of your desktop. From this popup, you can select “Allow” or “Block”.
This popup used to be On Top of everything else. This is no longer the case. It is very annoying, as there is no idication that something is “asking” to connect, unless you minimize all windows that are in front of it.

Does anyone have this issue?

Kind Regards,

Good find… have the same issue with new connections

Yep, getting that too (Windows 10, on v2.3.444).

Glad that I am not the only one.
This is changed behavior, right? I never noticed this before…it seemed to have always been on top in previous releases…

Same issue, (W11 Insider, v2.3.444)

They don’t believe me when I told them. I’m running up to date Windows 10. Here’s the first response.

*Hello ****,
Thank you for reaching out to GlassWire support. I hope your day is amazing.
It seems that the issue you are describing is related to the Notification Settings of the Windows 11 OS, as GlassWire has no such glitch currently. Please review and modify the particular notification settings from the Windows Settings as per below:

Change your action center settings at any time from the Settings app.

1. Select Start , then select Settings .
2. Select System > Notifications & actions.
3. Do any of the following: Choose whether to see notifications on the lock screen. Turn tips, tricks, and suggestions about Windows on or off.

Let us know if further assistance or help with anything else would be necessary. Have a lovely day!

Best regards,

GlassWire Customer Care

Second response.

Thank you for the follow up.

I did test it and tried to replicate it, but my notifications works as designed, appearing in front, on top of all other windows. Please share some additional information like screenshots, so we could think of a solution.

Looking forward to your reply. Have a lovely day!

Best regards,

I replied with screen shots. Waiting for a response.

Looks like it’s fixed in v2.3.449

I haven’t noticed this but I completely despise the Devs for not allowing the program to be resized. It’s too big and I want it shrunk back to where it had it before so it doesn’t cover somethign else important up I keep open and off to the side in the background all the time.

I’ve had an issue for a very long time they refused to believe me with as well… 2 actually. Their program is recording double the actual usage and even showing proof I wasn’t believed. Their mobile version records mobile data when my mobile data is turned off and I have absolutely no service where I live, so there’s no possible way it can be recording mobile data, yet they refused to believe me because “everybody has service of some sort”. Well not me, there is no service here, no tv here, no internet outside of satellite internet. People do live in rural areas where technology is not available to them still because the towns are too cheap to do anything for them about it.

I can confirm this is fixed in version 2.3.449.