Could not upgrade to new Glasswire unless reboot done

Got notification this morning that there was a new version of Glasswire. Since I have Elite version I decided to upgrade one computer here to begin with that is using Windows10 Pro. Downloaded the exe file and ran it which complained that it could not replace the GWIdlMon.exe file.

Had to reboot the system and redo the installation. Is this normal for Glasswire updates to have to stop every thing areboot the computer in order to get the software upgraded? Should I have closed Glasswire down first before running the exe file? Its just that I have several computers to upgrade here.


No, it is not normal for GlassWire to require a reboot on install. I will report this to our quality assurance to see if they can recreate this issue. Thanks for your report.

May I ask what Windows version number you use (Windows 10 Pro)?

Windows 10 Pro 1809 was the version I wanted to upgrade. I also have Glasswire on a 1903 system that I could see how it works.


This error happened with both your computers, or just one?

I only tried the 1809 upgrade. Havent tried the 1903 YET.

1 Like