Failed to install new version

I’m using Glass wire for about 5 months, I always keep my software update, so I downloaded the last version of glass wire to update it. During the installation I get " Installation Failed", (maybe some certificate issue?)… I tried to uninstall and reinstall it but nothing same error… The strange thing is that after the message Glasswire is installed but can’t connect and also I’m back to a free user (which I’m not because I paid for it)…

What can I do?

Could you uninstall again, then go to your “programdata” folder and delete the “glasswire” folder and then try downloading our latest version and try to install again? Sorry for the problem.

Nothing’s changed… same error

Could you email a screenshot to our helpdesk? Sorry for the problem.

I was having the same problem - uninstall and reinstall did not seem to solve the problem, which was as described by the original poster above.

I did eventually find the program data folder (took a while!) and deleted the Glasswire folder within it. Then downloaded and installed a new copy of Glasswire.

In my system, this seems to have worked. I’m running Windows 7 Professional 64-bit.

Now it works… I don’t know why… ty for the support


good afternoon
Today I downloaded GlassWireSetup v2.2.304.0 from the official website, I had never used it before, and when I go to install it I get the attached poster. I have already read what is written in this post and I do not see information to solve this problem, if you could assist me please


Sorry for the issue. May I ask your country location?