Firewall always Disabled - cant enable - high CPU

Hello there :slight_smile: I am now a long term User of GlassWire for about 2 years now and I´ve never had such an issue or any problems with it. Now for about a few Months I just cant enable the Firewall running on my Machine. On any other Machines its running just fine. On my Main PC I am missing this option/ the Button ist just greyed out. Whats the problem here? Plus in TaskManager I always find “LocalServiceNoNetworkFirewall” Task with “Windows Defender Firewall” utilizing 20% of my CPU after boot up for about 10 mins or more on a 8 Core Machine so thats a lot utilization.
System is Windows 10 on 1809 | 17763.529 64 Bit.

@EddyT95

Thanks for using GlassWire!

On the firewall if another app is disable the Windows Firewall API we use sometimes GlassWire can tell you what that app is. Are you seeing any notice like that? If you are try doing a search online for “appname Windows Firewall” and you may see some ways to continue using that app while not making it disable the Windows Firewall API.

If I was in your situation, and if my GlassWire History and Windows Firewall API rules did not matter so much I’d try the following:

Uninstall GlassWire in add/remove programs.
Go to the Windows Firewall control panel and choose “restore defaults”.
Reboot. - IMPORTANT

Reinstall GlassWire using our “clean install” and “reset firewall” options.

Now see if the issue is resolved.

It is doing the same for me now, after updating to Win 10 1903. GW does not give me any hint about what is causing this.

  1. System Boots up
  2. High CPU for about 5 minutes
  3. During this time, the GW Firewall is off and greyed out
  4. After the CPU usage dies down, the Firewall is on.

I don’t want to lose all my collected traffic data. It is, after all, one of the main reasons why I got GW - to see the history. Any ideas on how to proceed?

@silunare

Do you use Bittorrent or something similar?

Are you using our latest software? May I ask the version? Go to our top left menu and choose “About”. Thanks.

  • I have used Bittorrent software in the past on this PC, but there’s nothing autostarting and no associated service running, so it shouldn’t be of any concern IMHO.
  • I am using version 2.1.158 Elite.

@silunare

If you are worried about your settings/history, it’s possible to back them up.
https://www.glasswire.com/userguide/#Backup_Settings

Meanwhile I’ll discuss this issue with our team and see if they have some ideas. When this happens does GlassWire’s graph/apps show anything unusual?

Recently I have been getting some problem in my system because my Skype was no working at all and I need to Fix Skype Mic Not Working problem so that I can chat again. I think that this problem is due to firewall which is blocking the access to the mic.

@mikepatinson007

GlassWire has no ability to block your mic. Is Skype not working at all and has no network connection, or is just your Skype mic failing to work?

Are you a free/paid GlassWire user and are you in “Ask to connect” mode or what mode? If you switch our firewall to “Off” does your mic work?

Hi,

i am facing the same problem what @silunare has reported.

GW vers : 2.1.158
Windows 10 64 bit with all the latest updates.

Thanks,
Ganesh

@adhitya

Did any of the tips for Silunare help you? How old is your GlassWire history?

Hi Ken,

Only option left out is to reinstall the GW which i want to save for the last resort solution. Is there any other option i can try to resolve this issue.

Thanks,
Ganesh.

@adhitya

We will have an update out in the next week or two. I recommend waiting for that if possible.

Also, we’re completely redesigning our Windows service currently and the release after that will work in a completely different way. Meanwhile we will try to reproduce this on our own machines.

Any news about this update? I am experiencing this issue for the first time. I noticed that the firewall wasn’t working when an app that I blocked was communicating to the internet. I then toggled the firewall off, but was not able to turn it back on again, even after a restart. I have also experienced the high CPU usage with LocalServiceNoNetworkFirewall. Any fix would be great.

1 Like

@Kyle_Mohr

Does your firewall show that another app has blocked the firewall from turning on? Usually it shows an error with an app name.

I was able to resolve the issue by restoring to default in Windows Firewall, however I still have the high CPU issue for the first few minutes that my PC is on. Is this a known GlassWire issue or should I troubleshoot elsewhere?

@Kyle_Mohr

I think most hardware can cause high CPU usage in the first few minutes their PC is on as its getting started. You can right click the Windows taskbar and check the task manager and see what’s causing the high CPU usage. If it’s GlassWire doing it please let me know.

We will have a GlassWire update out this week or next.

Hi Ken,

For now i am able to enable the glasswire firewall using the method suggested by @Kyle_Mohr. During the startup LocalServiceNoNetworkFirewall process occupies close to 40%+ cpu and after the windows defender firewall reset the LocalServiceNoNetworkFirewall goes back to normal cpu utilization. Any idea on when the glasswire update is coming ?

Thanks,

We plan to have an update out this week.

Hi. I too have noticed that the firewall setting is greyed out. Updated to 2.1.166 today with a clean install but no change in firewall - remains greyed out.

@j9ksf

If you wait a while does the menu change so it is no longer greyed out?

Are you using another app that disables the Windows Firewall API? Or that accesses the API simultaneously with ours?