Firewall not turning on after sleep/reboot

so, I am on version 2.2.60;
but recently (not sure exactly when, but perhaps after windows update) when I reboot or bring my PC back on from sleep, the glasswire menu looks like this :

and the firewall is turned off (in windows) - can anyone direct me to see why this setting doesn’t stick?


Sorry for the issue. This is not a common problem that I have seen. I and our QA has the latest Windows updates and we have not seen this issue yet.

Do you use any other security software, if so may I ask what you are using? Are you using any other firewalls that could be interfering with ours?

I use no other firewalls, and I do use ESET for my A/V (A/V only because over time I prefer how GW works, so that’s my only “firewall”)

I am sure I will need to submit some logs - but in addition to this - when i switch modes (from say “block all”, to “Ask to connect” for example) it took nearly (I may be estimating wrong) 30 seconds to finally turn back on and allow the traffic again.

manually turning the windows firewall off and on - takes argubly, zero time.


Which version of ESET do you use? I found this article. It says one version of ESET should work fine with GlassWire while another will not.

We use the Windows Firewall API for blocking because it’s trusted by over a billion Windows users, it works whether or not GlassWire is running (if your PC is booting up or even if GlassWire is killed), it doesn’t conflict with other apps, and it’s super light on resources.

That’s about right. There was a time when there weren’t those nice animated dots.


It depends on how complex your rules are if there is a loading time or not.

Previously there was a loading time also in some situations but we had no loading animation for it, you just didn’t know it wasn’t finished loading yet.

Just coming back after I had some other issues -

as stated I am not using ESET firewall. I am using Windows/Glasswire.
I find it rather degrading that the ONLY question you asked was answered already.(I even made it a point to say I wasn’t using it, even though that’s the product I buy)

and conveniently ignored the question(s)

and to be fair, saying it’s being used by over a billion users doesn’t actually “HELP” your case, internet explorer is used by as many, and is considered totally crap and Microsoft begs people to not use it.

anyway, it still happens; the firewall randomly turns off, or doesn’t turn on when coming awake.

Sorry for the problem.

I believe @Ken_GlassWire was saying that one version of ESET has a built in firewall, while another does not. I don’t believe there is such a thing as “ESET firewall” specifically, but one version of ESET has a built in firewall that could cause the problem you are experiencing because it would disable our firewall and make it show as off.

The ESET link says “Running two firewalls on your operating system can lead to conflicts and configuration errors.”

If you could check what version of ESET you have then it could help us find the problem and fix the issue.

kinda explains it right there - but because that makes no sense -

I totally understand there is extra non-glasswire information, and I can understand how that confused people, even though I said “this isn’t being used” - and that it’s only A/V.

sorry if I seem frustrated, it’s because I am. the only effort I saw so far - is telling me, a product I said I didn’t have, could have problems.


Please do the following:

  1. Go to add/remove programs. Make sure there are no other firewall apps installed that might have been forgotten. If there are, please consider removing them because they can conflict with GlassWire.

  2. Uninstall GlassWire in add/remove programs.

  3. Go to the Windows Firewall control panel and choose “restore defaults”.

  4. Reboot

  5. Install our latest version and check the box “reset firewall”.

Now use GlassWire normally and the issue should not happen again, unless you are using another app that is using the Firewall API we use and conflicting with GlassWire somehow.