Firewall Profiles

Hi,
I try to use more Firewall Profiles, one for home, one for surfing on the web outside my home…
All my Profiles are set to “ask for connection”.
Today I create the surfing Profile, that allow only Firefox and Chrome…
Later I want to switch back to my Home Profile, but all settings lost.

@T-Ghost

Sorry for the issue, is this for Android or Windows? Both apps have profiles, and both have Firefox/Chrome apps.

If this is an issue with Windows, do you use any other firewall software simultaneously with ours that may interfere with the API we use for blocking/profiles? If so please uninstall it and it should solve the issue.

Hi,
I talk about Windows 10 up to date.
Windows Firewall is set to Standard settings.
The Profiles are not working correctly, I try to create a new one with standard and use current settings…

Please don’t tell me to make a clean Install!

1 Like

You should not have to, unless you use another firewall software that conflicts with ours.

If you go to our top left menu and choose “About”, what version of GlassWire do you use?

Always up to date
Version 2.2.304

I tested with that version and I was unable to recreate the issue. Is it possible you forgot to save the profile? If you try it again now does it make and save the new profile? Please be sure and press “OK” to save it, otherwise it may be lost.

I apologize for the issue and I’ll ask our QA (quality assurance) to also test for this.

The only Button that I can see is Create:
2021-04-30_205523

I have 1 Main Profile
Then i create a new one with “use current firewall rules…” option
In the new Profile I delete inactive apps first, then change the rules what I need.
Later when i switch back to the old one, this have the same settings as the new one.

Also a Problem, when I delete inactive apps (or another also), is’ deleted in all profiles.

Now I make a test at another system, clean win 10 and clean GlassWire installation.
After this I install Firefox ang Google Chrome.
Then I create two profiles: 1 Firefox only and 2 Google Chrome only.
In every profile I block all except the browser, that works great.
But when I block a App in one profile, it will be added in the other also as non-blocked.

See my small example video:
https://www.upload.ee/files/13102668/2021-04-30_21-43-00-224.mp4.html

Many Apps make the switching the profiles slowly also.
Is it a Problem or a limit for Apps in the block list or Database?

Thanks for this detailed report. I’ll share it with our QA to investigate so we can try to recreate this and help you solve it.

Thanks for reporting this issue. We tested for this issue in detail and this is what we found:

You said “Also a Problem, when I delete inactive apps (or another also), is’ deleted in all profiles.”

We believe this is correct behavior because we designed GlassWire to work this way with profiles.

You also said “Now I make a test at another system, clean win 10 and clean GlassWire installation.
After this I install Firefox ang Google Chrome.
Then I create two profiles: 1 Firefox only and 2 Google Chrome only.
In every profile I block all except the browser, that works great.
But when I block a App in one profile, it will be added in the other also as non-blocked.”

Unless we’re misunderstanding then this is how we designed the profiles, because you should confirm every app in each profile separately.

Overall, we think this is a misunderstanding caused by the fact that we are mixing the complete list of apps with the firewall profiles. However you expect separation. So unless we don’t understand you correctly we have purposely designed the profiles to work this way.

Our team will discuss your feedback and consider making changes in the future. Thanks for your detailed report and feedback.

Yes, but it doesn’t work good for “Ask To Connect”, because in the other Profiles it will add as allowed and don’t ask anymore.

1 Like

Thanks for your feedback. We’ll see if we can improve that in the future.