Glasswire .is crashing after days on all Servers and all Workstation

So, this is getting Serious now, dont tell me you cant see it for yourself,

after 3 Days GW is crashing on all 6 Different Windows 2008 R2 Servers, i mean potent machines with dual XEON / 32 GB RAM, ok some of them Single XEON and these are stable since 1 Year Build lately 2015
and since then running stable.

No matter if i restart the Service daily or quit the Console and let only the Service run in the Background.
Some Machines Freezes without Responding anymore , some machines show:

so dont Tell me the Logging Version, i cant Log every single Machine.
This is a principial Error, how can you promise unlimited Logging if the Service is crashing even after 3 Days?

And Yes the Service is even crashing on a VM with Windows 10 and there is only one little Test Webshop Database JTL on it. SO I can say it is crashing Everywhere.

The Desktop is Filling with DUMP Files on all Machines.


I think there is a misunderstanding. In the other thread where you posted this I asked you to email us with a link to the thread so we could provide you a logging version of GlassWire so we could check the crash logs and see what is happening and fix the problem.

Maybe this isn’t even required since you have DMP files. Please email us the DMP files (it may require a cloud service if they are large) so we can investigate.

As I mentioned in the other thread, we had another Windows 2008 server customer with this problem but updating to the latest Windows Updates solved the problem for him. I think you said you already tried this though.

Sorry for the problem and we look forward to receiving more details and logs so we can investigate and help.

The DMP Files are in Range from 45 MB to 1,7 GB which one do you want? And does the files include passwords or sensitive user Data maybe Email Logins or RDP Sessions?

GWIdlMon.exe.16240.dmp 45 Megs
GWCtlSrv.exe.149936.dmp 1,7 Gigs ZIPPED is this 219 MB

You can analyze the file before sending them. Here is info on what dump files are

We’d like both files if possible.


Dump Summary
Dump File: GWCtlSrv.exe.31888.dmp : C:\Users\Алексей\Downloads\GWCtlSrv.exe.31888.dmp
Last Write Time: 12/14/2016 3:56:49 PM
Process Name: GWCtlSrv.exe : C:\Program Files (x86)\GlassWire\GWCtlSrv.exe
Process Architecture: x86
Exception Code: 0x40000015
Exception Information:
Heap Information: Present

System Information
OS Version: 6.1.7601
CLR Version(s):

Module Name Module Path Module Version
—--------- —--------- —------------
GWCtlSrv.exe C:\Program Files (x86)\GlassWire\GWCtlSrv.exe


Are you the same person as above who started the thread, or someone else?

This is another Person, Status at us is, i removed GW from all affected Machines and i have no time to debug for myself, i try it on some VMs in hope to get new Debug Files, and after today i have to start from begin because of the latest 2 Windows Updates maybe the nature of the crashes will change.

Latest Status from yesterday prior the latest Updates:

  • VM Freeze without Debug Files, First VM is a JTL-SQL transfer VM / Second is my Debug and Test VM
  • File and Mailserver “D1” Bluecreen after < 3 Days, removed again

All Systems Windows 10 / 64
and Servers 2008 R2s with all SSD and Raid 6 LSI


Sorry for the problem. Is the VM stable without GlassWire installed? GlassWire should generate a dmp file if it was the one that crashed.

Yes the VMs are stable without GW and freeze with GW installed in Short times. Virtual Box Windows 10 - 64

Please send a dmp file once you get one, then we can investigate and fix it. Sorry for the problem.


Are your servers/PCs completely up to date with Windows Updates now? I wanted to confirm so I am sure I understand the situation. There are some known problems with un-updated versions of Windows 2008 server but updating it fully solved it for our other customer.

Yes alle Servers are up to date, now i begin to share the Debug Files / Mail is sent


We got them. We will investigate and try to fix this, thank you for your reports.

THX , but Ken, i have some servers running 1.2.76 and these are all running fine. and i used GW long long before and never saw such hard crashes. Maybe you should consider the last changes to …79 :wink:


We sent you a new version to test, please test and let us know the results. Thanks.

Cool! THX i Will install it now :slight_smile: for the Weekend running

1 Like

Good News:
Seems better now, no crashes on Weekend, Rolling out this Version on all Servers to Check… Hold on.

Server4: GW Seems Stopps loggin after 1 Day / reinstall


Please respond to the helpdesk email that sent you the version to test so we can help. On the server that stopped logging, does it have limited memory? Also, did you do a “clean” install when you installed the test version we sent?