Glasswire 2.0.123 and window position/size


#1

Is anyone else having trouble with Glasswire free addition not saving windows position or size? This just started with the new updated version 2.0.123 for me, all previous versions I have used worked fine (other than the short lived service not starting back in one of the version 1 builds. After checking numerous settings and file permissions even, the only thing I am left with but haven’t checked yet is registry settings. If I find a fix after checking in the registry I will post it. but may not get to it for a few days. Hopefully someone has had this issue and found a fix for it and will post before I get to it.

Specs:
Operating System
Windows 7 Ultimate 64-bit SP1
CPU
AMD Phenom X4 9500
Agena 65nm Technology
RAM
8.00GB Dual-Channel DDR2 @ 401MHz (6-6-6-18)
Motherboard
ASUSTeK Computer INC. M4A78 (AM2)
Graphics
P205H (1600x900@60Hz)
1024MB ATI AMD Radeon HD 6400 Series (MSI)
Storage
1863GB TOSHIBA HDWD120 ATA Device (SATA )
1863GB TOSHIBA HDWD120 ATA Device (SATA )
28GB SanDisk Ultra USB Device (USB )
Optical Drives
HL-DT-ST DVDRAM GH22NS50 ATA Device
Audio
Realtek High Definition Audio


#2

I’m not sure whether I have the same problem because I need reproducible steps.

Which scenario doesn’t save the window position?

  • close and reopen the GlassWire window;
  • wake Windows from sleep or hibernation;
  • start Windows after shutdown;
  • or something else.

#3

Mostly waking up from sleep and reboot/starting windows, though every once in a while it will do it just by opening Glasswire after not opening it for a day or more.

I did check the registry and I didn’t find anything that might effect it. But then not having the source code I had no way of checking if there were any obscure settings someplace not obvious.

Also, Just this week I have shut off sleep function in Windows because my backup software was having an issue with not always waking the computer to backup.


#4

Thanks, I’ll try those and see what happens for me.


#5

Another question: Was the GlassWire windows in focus (the current window) each time?


#6

I can’t reproduce it and I suspect it is the same problem reported in another topic:


#7

Yes i have reported this Apr 14 2018 Here was my post “Hello,
I have noticed that GW is not “always” remembering the window position and size I set.
In time it ends up in the very top left-hand side of screen, and reverts back to its original size. This was a problem in the past which got fixed with an update, but it is back again for some reason.
I have the latest version 105 installed. FYI. This also happen on the previous version 102.
OS Windows 10Pro.
Thank you.” A few others user said they have the same problem. I still have this issue with no fix and now using windows 1803 Build 17134.159 . Ken maybe if you see this and in a future version we can have an option to tick (Remember Window size and position) I Have have seen this in some apps. Or if not, can this be fixed up please?
FY.I My GW is the current version. Thank you


#8

It happens when I open it from the system tray (Sorry should have mentioned that in the first post.) Also when it reverts to the size/position I don’t want, it extends across 9/10ths of the screen along the bottom. While i have it set to bottom right and smallest size it will go horizontally. And vertical size is just enough to show four entries on the alert screen. Again, it happens most often with a reboot. And lastly this is happening on both Windows 7 machines but not on Windows 10. Both windows 7 machines are really close as far as setup.


#9

In Windows 10, I tested those things too so thanks for confirming them:

  • opened from the system tray
  • set size to smallest (fyi, text size is the default)
  • bottom right position

#10

Please provide step by step numbered instructions on how to recreate this, then I will forward them to our QA so we can recreate, then fix it.


#11

Ok,

Step 1: size window to preferences using the sidebar dragging.( My size is shrinking display from left to right as small is the program will let me.)

Step 2: Size window vertically to preferred size using same technique as step 1.( My size is enough to display 3-4 alert messages on the alert screen.)

Step 4: Close display window with the red x with it set to close to system tray.

Step 5: wait awhile. (As little as 3 hours has worked in reproducing it.)

Step 6: Reboot computer and once running fully open Glasswire from the system tray and size will be back to what it was before you resized it.(While this happens most often with a reboot, not all the time, seems to be about 90% of the time on reboot, 50-60% on recover from sleep mode, and about 10% just happens with no reboot or wake up from sleep, Just out of the blue so to speak.)

Do hope they find the issue, but not too worried if they don’t, I mean the program still works fine and this is just a nuisance. To me it is not a “make or break” issue.


#12

Do you ever see this same issue with games or other apps? Do you play games? Sometimes games can cause your screen to resize, and it resizes other apps outside the game. In this case it’s related to the OS and not GlassWire.


#13

I do play games, but none resize my screen and this issue happens even when I haven’t played any games. And no other apps have this issue.


#14

Ok, not sure what is going on but now it is working fine and has been since about 7-10 days after the last post.


#15

it’s happening to me too but I can’t find a process to recreate the issue, it just happens sometimes


#16

Yes it still is happening for me, I have given up, and just have to put up with it. As they say nothing is perfect.


#17

I’ll keep trying to recreate this on my end. I don’t reboot a lot myself, so perhaps that’s why I don’t see it.

I will ask our QA to test more also.


#18

Thank you Ken, Yes i reboot every day and the problem can take a good week to recreate.