GlassWire 2.0 issues

  1. This a BIG one, the network tab is enabled by default, with no option to disable it. I had installed 1.2 on two servers I have in the cloud to help me monitor which processes where consuming how much traffic and upgraded them to 2.0, only to find it does a periodic ping sweep which raised all sorts of alarms at my hosts not even two minutes after installing it. To make things worse, I couldn’t disable this feature forced. I had to immediately uninstall it. Had I been foolish enough to install it on my laptop at work (I’m a software developer), I’d have gotten in trouble immediately with IT security. Doing unauthorized network scans will get A LOT of people in trouble at work!

  2. Still no search function for neither processes nor IP addresses. This is the single biggest feature I was waiting for to buy GlassWire.

  3. Annual subscription model with no option to buy a perpetual license (at least not one that is easily found on the site). I wanted to buy the 10 license pack to use on my machines at home and servers in the cloud. $199 is ok for me for a one time fee, but at $99 you’re charging what Microsoft charges for the family pack of Office 365!

  4. This is also somewhat important on a server: the dependence on wlanapi.dll. The Wlan auto config feature/service is NOT installed by default on Windows Server, nor is it needed on a machine that doesn’t have a wireless card. There shouldn’t be a hard dependence on this service.

  5. I’ve just found this one on two machines I’ve rolled back to 1.2 after unistalling 2.0, GlassWire will stop working. The GlassWire control service would crash immediately when I start the app. Checking event viewer, I found this error:

Faulting application name: GWCtlSrv.exe, version:, time stamp: 0x5a1d2f52
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f7ce6
Exception code: 0xc0000409
Fault offset: 0x000a7666
Faulting process ID: 0x2920
Faulting application start time: 0x01d37528ed0f3902
Faulting application path: C:\Program Files (x86)\GlassWire\GWCtlSrv.exe
Faulting module path: C:\Program Files (x86)\GlassWire\MSVCR120.dll
Report ID: 003fdaa6-04f4-4e7b-b2a9-d9c696ad0d7d
Faulting package full name:
Faulting package-relative application ID:

EDIT: Solved the last one with a clean install.

I’ve just sent those issues as feedback, but I think users need to be aware of those before upgrading.



Thanks for your feedback. I’ll comment on your numbered reports below.

  1. Actually the network tab should be disabled by default for new users. The first scan just checks ARP tables one time only and isn’t technically a scan. You must press the “scan” button to scan manually, then to make it scan automatically you must switch that on with GlassWire’s settings. Did you upgrade from 1.0? Perhaps somehow a user from 1.0 who upgrades had this on by default? Please let me know details and we’ll try to recreate this.

  2. Working on it. Please request it here. Future Feature Requests!

  3. We offered a perpetual license for several years and you never upgraded. The new subscriptions are priced lower and allow us to fund continual development. Please also note original GlassWire purchasers are getting a free upgrade to 2.0.

  4. Please report in our feature requests, thanks.

  5. I’m glad the clean install fixed it. If it happens again please email us any .dmp files you may find on your desktop if possible. Or, make sure and run Windows Update on that machine first if possible. It may also fix the issue.

We’ll keep working hard to improve, and of course with any new major update not everything will be perfect but we’ll try our best.


Hi Ken,

Thanks for the prompt reply.

  1. Yes, upgraded from 1.2.121. Basically, uninstalled 1.2 and installed 2.0. Running on Server 2016, it failed to start due to wlanapi.dll (WLAN feature), so I installed that feature and restarted the machine (the windows feature requires a restart). Once the server restarted, I immediately received automated warnings from my hosting provider (two warnings) that my box was doing ping sweeps. Luckily I hadn’t restarted the second server. I run ntopng on my home network and that too raised an alert on the IP of my laptop. Win10 Pro, latest updates, upgraded from 1.2.121 to 2.0.

  2. I actually have commented there 9 days ago asking for search, and for the ability to scroll through hosts and apps without a pop-up window. The search function is pretty important to me, to be able to see which IP addresses are the most active with each service. Integrating something like nDPI or PcapPlusPlus to do L7 metadata logging would make GlassWire a killer server administration app.

  3. I found about GlassWire about two weeks ago, and spent sometime on the forums. Seeing the recent topics about the imminent release of 2.0, and not knowing what the upgrade policy would be regarding recent purchases, and what features would be included, I figured I’d play it safe and wait for 2.0.

  4. 1.2 didn’t/doesn’t have this dependency on wlanapi.dll.

  5. I had installed the latest updated just last night (patch Tuesday).

I know how hard and stressful major releases are. Please accept my apologies if my original comment was harsh in any way. Hats off for what is clearly a great product. I was just caught off guard by the alerts from my hosting provider and feared they’d disconnect my servers.


Thanks, I’ll report these problems to the team so we can get them fixed!


I don’t mind paying for software I find useful, even if there’s a free version that meets most (or even all) my needs. As I said above, I work in software development, and appreciate how hard it is to develop a product, and get it out the door. I think of it as a token of my appreciation to the developers. Obviously, I’d also have to find the price-value proposition to be fair, but In GW’s case, had it provided the search functionality, $20 per monitored machine is great value proposition. I’d expect to get get 3-4 years of use out of it, making it $5 per year per machine!

Had it had Layer-7 metadata logging, along with search, I’d be more than happy to pay the $99 annual subscription, since that would transform it into a network traffic auditing tool. There’s just no similar product catering to those of us who can’t afford those four or five digit price-tag offerigs.



Our team asked if in your settings, was your “Things” scan switched off when this scan happened? Any idea?


I don’t remember whether this option was enabled by default, to be honest. The exact steps I took were:

  1. Uninstall 1.2.1 (no 3rd party uninstallers).
  2. install 2.0 without cleaning data (wanted to maintain the app’s history).
  3. Choosing to start GW 2.0 at the end of the setup wizard, at which point I got the wlanapi.dll error.
  4. Added the WLAN service feature to Server 2016 to resolve this dependency.
  5. Restart server to finish WLAN service installation (required by feature).

GW auto-started when server restarted, and not a minute afterwards I received the first warning email. Spent a minute or so trying to figure out how to disable it, but didn’t change anything. As I said before, the latest Windows updates were applied Wednesday.

A few seconds after that, I received the second warning email from my hosting provider, and at that moment I made a snap decision to turn off GW 2 and uninstall it to prevent losing connectivity.

I realize this might be being overly technical (hence the geek part :stuck_out_tongue:) but I was expecting to see an option containing the word “network” in it, which was what I was visually scanning for. I also wasn’t expecting the free 7 day trial, since it’s not mentioned on the site. I know now this was mentioned in the newsletter, but I read the title, and went straight to the site to read about it.


I’m not sure how not being able to afford expensive solutions can be procrastination. $20 might be pocket change to you, but its not in many parts of the world.

Idon’t believe metadata logging is a niche offering. Everybody is moving to the cloud, and most current solutions for this sort of thing still assume local infrastructure, where one can “tap” the cable connecting the server. The metadata logging can always be sold as a separate SKU for those who need it.

As for freelancing, I’d love to, but my area of expertise is .NET and web development, and GW is written in C/C++. Very little overlap there. What I can provide is technical feedback, and I’m more than happy to help with that.



We appreciate your feedback. I agree we need more info about the trial. This is our first “trial” software so we’re new to this type of application.

We understand how $20 is a lot of money and we appreciate that. Please join our email list on our download page to get alerted of special deals for our email newsletter readers.

I’ll discuss your comments with our team. Thanks!



We spent a lot of time and could not recreate the “Things” scanning problem. This setting is under general settings like the image below.

Are you sure it was switched off? We’re preparing an update and we want to be sure nobody experiences this problem.




I never touched anything in the options window. I tried to detail the steps I went through in my previous comment when installing 2.0 to the best of my recollection. Please note that this was on Windows Server 2016, and not on Windows 10.

Do you log any messaged to event viewer? I don’t mind providing those if there’s anything there.



We don’t log anything there. We’ll have an update out tomorrow probably. I hope you’ll give it a try with a clean install and see if this problem comes back or not (if it’s OK with your IT person).



The issue happened with a normal install (not a clean install) as I described in the previous comment. But sure, will try to replicate it once the new version comes out.


Thanks. The update should be out tomorrow.


The problem is now solved, please upgrade


Hi Ken,

Just downloaded the latest version and installed it on my home server (also running Windows Server 2016). First, I removed GW 1.2, and then I did a clean install of the latest (2.0.80). Again, the things tab immediately showed all devices on my local network. I am attaching a screenshot of GW 2.0 along with the settings window. I have NOT touched any option on the settings window. The Things tab was populated within very few seconds of starting GW 2.0.

I repeat, I did NOT touch anything in settings, and on first start, GW showed me I have 17 devices on the Things tab :worried:


while true it’s kinda sad to see that non-elite customers are paying about 50% more already in the second year, and it gets of course more and more each year.