Glasswire 2.2.268 stops network printing to Brother Printer

I have seen this before and stopped using Glasswire. I tried Version 2.2.268 and like what I see, but then there’s this no network printing issue. I uninstalled 2.2.268 and network print jobs print. I should also relate that after I uninstalled Glasswire; it required a computer restart to correct firewall status. No other changes to system and it was working well previously. Please fix this, as I and others here like printing alot. For now no Glasswire installs.

@Speedy

I apologize for the problem.

I personally use a Brother printer on our work network. Even in “Ask to connect” it asks to connect, then I am able to print.

What Firewall mode are you in when this happens? Are you on Ethernet or WiFi, and how is your printer connected?

This is what I see in “ask to connect”. After I allow this I can print.
spooler

I would also like to add that I don’t recall anyone ever reporting that our software required a restart to correct the Window Firewall status, so that’s a new one for me. What OS version do you use?

Are you using another firewall app with ours, or have you in the past? In that case perhaps it has some left over files causing this issue.

You could uninstall GlassWire in add/remove programs, then go to the Windows Firewall control panel and choose “restore defaults”, now reboot.

Now install GlassWire with its “clean install” and “reset firewall” options checked.

Hi Ken,

I had experienced this issue around version .240 or .241 as memory serves me! I had to remove Glasswire from all workstations. It was the fastest way to get printing back on line. I unfortunately became distracted and didn’t get to post this issue. More recently, It was interesting that Malwarebytes had a similar issue and was able to patch their way around it. The printer is Ethernet connected and so is the workstation I’m currently using for test. The test workstation is Windows 8.1 Pro 64bit. I do have some workstations(Laptops) connected via wireless access point. OSs used are Windows 7 SP1 Pro 64bit, Windows 8.1 Pro 64bit, and Windows 10 Pro 64bit. I use Malwarebytes on all systems and they all failed to print using the network connections during the Malwarebyte issue.

I did previously run Glasswire on all workstations, but stopped doing so when the network printing did. I use no other firewall on any workstations and had no printing issue prior to upgrading to the the .241 version and now again with .268.

I have never used the click to connect feature. I guess I just assumed that the Windows firewall would not be change in that way without some manual changes?!

I used add/remove Glasswire in control panel in any case, followed by a reboot to regain printing.

I will try the click to connect function and get back to you. Thanks for the quick response and hope to have Glasswire up running everywhere soon.

Speedy

1 Like

Hi Ken,

Using the click to connect allowed printing! I then switched back to click to block and it was still good. Hope this holds and test for awhile. If good, I’ll install on all workstations.

An interesting issue that came up with the Malwarebytes not allowing network printing, was that during our testing phase, the printing would work for awhile and then stop. I believe it had something to do with the “deep sleep mode” the printer needs to be awakened.

Thanks again for the quick reply and a way to drive Glasswire to a better place.

Speedy

2 Likes

Hi Speedy
I had a printing problem when I was in Ask to connect and did not get a notification to allow the spooler SubSystem. So, I just changed the firewall setting to click to block and then the printer worked. Then setting the firewall back to Ask to connect. No more printing problem.

1 Like

Thanks for the feedback. You help me remember the original problem with the prior release. I would make use of the Block All mode, while I was away from the PC. When I turned Block All mode OFF; the network printing didn’t come back, which included the Brother printer monitor icon was then grayed out, indicating it can’t find the printer status.

Thanks for the help. I need it at times! Speedy

2 Likes