Glasswire 3.2... won't install, fails to uninstall...? (Resolved)


As you can see I am trying to INSTALL glasswire however it’s failing to uninstall an old version, that no longer exists… no uninstaller, no directories or files, no services, and as far as I know no registery entries exist…

Why can’t I install?

Hi GayNamedPaul
Maybe tick the options when the installer gets to Clean Install (Clear Data & Settings)
and also tick restore windows firewall default setting. See screenshot options
Not sure if it will work but give it a go.

Thanks for the reply, I had already tried that. Same response… for some reason the installer thinks Glasswire is still installed?

Hi GayNamedPaul
You could try this which was suggested by another user



Tips to fix-
Delete our installer.
Reboot your PC.
Download our latest version again from glasswire site.
Double click the installer and do nothing else, then wait. Please look at the taskbar for any notices that you need to click. Please wait at least 2-3 minutes just in case.

If you had an old version installed anytime in the past? maybe you might have to search for bits left over and remove them.
Best to reboot each time when you do any of this.

Tried your advice, same problem. I did have an old version installed in the past, I’ve removed every possible remnant… but something is still sticking around. What’s frustrating me is that Glasswire have set the installer to uninstall the old version, which doesn’t exist anymore… instead of just copying over the files of the old version. I’m completely stuck, this is crazy. Can you get the attention of a glasswire employee, developer, etc? Or are you working with Glasswire yourself?

I am just another user like yourself. Just giving ideas that you can try.
Maybe look in the windows services and see if “GlassWire Control Service” is still running. Stop it and see if that lets you install the new version. In task manager kill any Glasswire processes that might be still running from the old version. If you have your old version you could try to install over the top again and don’t select clean install option.
Just other suggestions to try.

Problem solved.

I first installed older version 2.3.449, no issues appeared and it installed successfully. Second, I installed the latest version 3.2.490 with no issues.


Hi, very good, happy things are now working.
All the best…