"GlassWire activation server could not be contacted" Issue

I bought GlassWire a while ago and re installed my Operating System. I used my registration code to Activate my GlassWire but noticed a few months later that my GlassWire still was not register. I tried re entering the code again but got the message “GlassWire activation server could not be contacted”. Anyone know what could cause that issue?

It could be a couple different things. Please go to the GlassWire Firewall tab and see if GlassWire has blocked itself from accessing our activation server.

Are you using Kaspersky? If so can you temporarily disable it, then activate, then see if that solves it?

Could you uninstall GlassWire, reboot, then reinstall our latest version with the “clean” option and see if that solves it?

1 Like

I re installed a clean version, but kept the permissions.

After some digging I realized that “GlassWire” was unblocked, but “GlassWire Control Services” was also, blocked causing the error. The issue is now fixed!

Being aware that unblocking “GlassWire” does not unblock “GlassWire Control Services” might help people in the future.

Good point, I will remember to include that information in the future. Thanks!

Hello, I am having the same problem while activating the Basic version—“activation server could not be contacted.” So far to solve the problem I have:
-uninstalled all virus scanners
-turned off all local firewalls (Glasswire and Microsoft)
-uninstalled Glasswire, rebooted and then installed a “clean” version.

Nothing has worked. I am using Windows 7 (updated). Any idea what is up with this program?


Are you able to reach https://activate.glasswire.com? If so it must be something on your PC blocking the activation. Some users have reported problems with Kaspersky and they needed to white list GlassWire.

Are you behind a Proxy?

Is there anything unusual about your network?

Hi Ken,

I can access that page you mentioned. I use a proxy server. Again, I don’t have Kaspersky or any virus scanning software besides Microsoft Security Essentials (MSE). I turned off MSE and still no activation.

I turned off both Glasswire and Windows firewalls. Any other procedures I can try?


Sorry for the problem.

Please uninstall GlassWire again, then reboot.

Next go to your Windows Firewall control panel and choose “reset defaults”. Next reboot (important!).

Now do a clean install of GlassWire using its clean install option. Did that work?

Do you use any unusual man in the middle type security or router systems that could be interfering with a normal SSL connection? Our activation system is fairly simple and I don’t see problems with it very often.

Hi Ken,
I followed your instructions carefully but cannot activate the software. Besides the proxy there is nothing exotic about my network. I can access HTTPS websites and never had problems activating proprietary software.

Can I try activating this software on a different computer running Windows? This would only be a test—I would want to uninstall so I can use this on the computer I purchased the license for.


Please email us for a custom version of GlassWire to test and see why this happens.