GlassWire and Nest Wifi

Hello all! I am hoping to get some advice on how to move forward.

Issue: Cannot connect to 3/4 machines that I want to monitor.
Fios Gateway (wifi turned OFF) > Nest Router providing wifi > PC 3, PC 4 on wifi
Nest Router > multi-port switch > ethernet cord 1 > multi-port switch > PC 1 (mine), PC 2
Fios Gateway (same as above) > ethernet port > PC 5

I am unable to connect to PCs 3 4 and 5 from my PC 1, but i can connect to PC 2 using the remote access feature. I’m sure this is due to some port forwarding issue but I would love some additional guidance:

  • Should I set it up as TCP or UDP or Both?
  • Should I set up static IP addresses?
  • Any other things I can try?

I’ve tried the first two several times to no avail but I will admit i am exhausted and might not be thinking clearly. I am tech savvy enough to be dangerous, so feel free to tell me to do whatever.

Thanks in advance.


Sorry for the issue. If you follow these exact steps in order does it solve it?

Are you using the same version of GlassWire on all the devices? We did recently change how the remote monitoring feature works so it’s important to use our latest software. Older versions are not compatible and we put a warning on our download page when we did this earlier in the year.

Hello Ken!

Thanks for your prompt response. I did follow all the instructions on that list and I haven’t had any luck. Only thing I can’t figure out is the “general” part in here: "Custom Ports - You can also change the port you prefer to use on the remote PC under the “Server List” tab in GlassWire settings, then under “General”. " - i don’t see anything for this under the general tab. I have also tried the public and private IPs and no luck. I am running version 2.2.268 on all devices.

I’m using ports 7010 for PC 5, PC 3 is 7020 and PC 4 is 7030 and their settings match accordingly in the remote access settings.

edit: I also decided to enable the port forwarding in the windows firewall to no avail.

Thank you!

1 Like


Are you able to ping the PC you are trying to connect to? If not, can you try to temporarily disable the Windows Firewall and see if it allows the connection.