Glasswire and possible AV false positives

Glasswire is reporting v1.0.25b.

Since the latest update, whenever I use Glasswire to launch a virus scan of a program, they universally come back with an alert “Application virus scan failed.” (In the log, failed AV scan lists them as infected, though I suspect there’s something else going on, maybe a breakdown in communication between Glasswire and my AV.)

I’ve just been using MSE, which reports up to date as of October 2, 2014.

Two possibilities - 1) I’m completely owned and everything I have got infected right when I updated Glasswire, 2) Glasswire is having an error reaching my AV, and logging that error as infections.

I don’t want to dismiss #1 offhand, I’ve grabbed some supplemental software like Malwarebytes, and tried Trend Micro’s Housecall for an online scan.

But some evidence points to option #2. If I write a new program, just a little script that pings google, where I can see all of the code, as soon as I run it, Glasswire reports its network activity, and then if I try to scan, Glasswire logs it as infected, even though no bytes in the file have changed.

If every file is infected, it’d be very useful to know what they are infected with, but I can’t find any more details on the infection from the logs.

Is this a known bug? Has Glasswire had trouble with MSE? (Apologies if it’s already been discussed, searching for infected on the forums gets a lot of hits on different topics.)

Thanks for any recommendations,

Windows 7 Professional 64-bit (SP1)

Antimalware Client Version: 4.6.305.0
Engine Version: 1.1.11005.0
Antivirus definition: 1.185.2035.0
Antispyware definition: 1.185.2035.0
Network Inspection System Engine Version: 2.1.11005.0
Network Inspection System Definition Version:

UPDATE: Uninstall/Reinstall of Glasswire eliminated the problem. So… either it’s fixed, or now the hackers just corrupted my new copy of Glasswire as I downloaded it. :smile:

It still reports as infected files that can’t be scanned, ie, files that are in the old logs, but no longer exist. Everything else is clean though.

1 Like

Thank you for reporting this issue. So far we haven’t seen this problem on our end but we’ll try to recreate it and fix it in the next release.