Glasswire block Chrome Remote Desktop

The Glasswire Firewall is blocking Chrome Remote desktop. When I put the option “Ask To Connect”, even if all active Apps are allowed.

@Jonnes_Derik

Sorry for the issue.

Is Chrome itself unblocked? It may need to be unblocked to use that extension, since the extension may send the network activity through the browser itself.

Or does the extension show up separately in the GlassWire firewall?

Yes, in fact, as a test it enables all active processes (including Chrome, and two from Chrome Remote Desktop) but just put “Ask to conect” that remote access stops working

@Jonnes_Derik

Can you confirm where we get this Chrome extension so we can test it? is it an official Google software in the Chrome extension store or is it something else?

Thanks for your report.

Yes, it is an official google extension, unfortunately the forum did not allow me to send the link because I am a new user. :frowning:

In addition, analyzing the processes, the two that have a lot of activity while in remote access, are the ones that appear in the image I sent (my OS is in Portuguese).

When I’m in “Click to Block” mode, I notice that these processes have a large flow of inputs and outputs, and I get remote access.

When I’m in “Ask to Connect” mode, these processes also flow in and out, however, access is never guaranteed, and I get the message:

“Unable to reach the remote computer. This is probably due to the configuration of the network you are using.”

It should be noted that I use Nord VPN, but this, in all tests, was DISABLED (not even the process was working at the time).

Hey, thank you very much for the quick reply ^^.

1 Like

hey guys, any news ?

In Some Firewall rules are applied wrong - #13 by SHADOW13
I found that ALLOW button from notification is not working correctly.

If you have the same issue and if you tried to allow access to the apps via notification, it might have kept it blocked.
Can open “Windows Firewall” setup and check “Monitoring” and Inbound/Outbound rules for the app.

This should also work as a fix, check Glasswire Firewall settings, both apps should be allowed:

  • remoting_native_messaging_host.exe (find in firewall: “Native messaging host for remoting host management”)
  • remoting_host.exe (find in firewall: “Host Process” or/and “remoting_host”)

If both are visible, click the fire icon to block it (it will highlight in red/orange), then click it again to allow it again.

If the issue is the same as I found, this should re-apply the firewall setting correctly.

2 Likes